Copilot for Microsoft 365 Tech Accelerator
Feb 28 2024 07:00 AM - Feb 29 2024 10:30 AM (PST)
Microsoft Tech Community
SOLVED

Strange update behaviour with M365 Apps for Enterprise

Copper Contributor

Hey folks,

 

I experience a strange behaviour when updating my M365 Apps. I initially wanted to switch from the Enterprise Monthly Channel to the Beta channel and set a local GPO (Computer Configuration - ...- Microsoft Office 2016 (Computer) - Updates - Update channel). This did not work.

 

Then I used the ODT and a customized XML to switch to the Beta channel. This worked perfectly and I am on Build 2208.

 

However, when I choose to update Office ("Account - Update options - Update now"), updates are found and installed even with this current build and when I re-open Office I am back in the Enterprise Monthly channel.
I am able to reproduce this by starting from scratch (custom XML) and then choose "Update now" again.

 

Is this a bug or a feature? ;) Or is there meanwhile an admin option to force users to stay in the channel chosen in the M365 admin center? I could not find anything about this...

Thanks in advance for your replies!


Best regards

Ben

6 Replies
best response confirmed by Ben-neB (Copper Contributor)
Solution

@Ben-neB if this is due to a policy, you can confirm by checking the following registry locations:

 

HKLM\SOFTWARE\Policies\Microsoft\office\16.0\common\officeupdate

HKLM\SOFTWARE\Policies\Microsoft\cloud\office\16.0\Common\officeupdate

 

@BobClements no, my client is not part of any AD and our company does not use Intune for management either.

 

The only policy was set by me as mentioned above but it did not change anything.

@BobClements Please read my initial post - I already did that.

@BobClements I took another look at the registry and you were right - I found  the other registry key containing settings for Office:

"HKLM\SOFTWARE\Policies\Microsoft\cloud\office\16.0\Common\officeupdate"
(the default path is ...\Policies\Microsoft\office\16.0\...)

There the updatepath value was set to the CDN URL for Monthly Enterprise. I switched that to Beta and now it stays on Beta. I think this has something to do with the MS security baselines which I imported some months ago.

Thanks @BobClements for pointing me into the right direction!


Best
Ben

Check out this article and verify if the mentioned Message Center Post (MC362760 ) is available in your admin center: https://docs.microsoft.com/en-us/DeployOffice/other/devices-updating-monthly-enterprise-channel. If yes, your tenant is part of this change and your device will revert to MEC at some point in time. If you want to revert this change, use the feedback button on config.office.com to request a revert.
1 best response

Accepted Solutions
best response confirmed by Ben-neB (Copper Contributor)
Solution

@Ben-neB if this is due to a policy, you can confirm by checking the following registry locations:

 

HKLM\SOFTWARE\Policies\Microsoft\office\16.0\common\officeupdate

HKLM\SOFTWARE\Policies\Microsoft\cloud\office\16.0\Common\officeupdate

 

View solution in original post