Office C2R Version 1711 8730.2127 - This product will not be updated.

Iron Contributor

Anyone else lose the ability to update Office after receiving Version 1711 8730.2127? 

I had a colleague who couldn't reproduce the error with previous Office bits then he updated to Version 1711 8730.2127 and now receives the same options as I do below.  Clicking on enable updates does not help.


18 Replies

Thanks for the reply but that doesn't seem to be the case for us.  We have multiple people who were able to update from the previous version to this one by clicking "update now" but once they get to this version the update option is gone.

Hi there

I have seen an issue like this before and it was caused by incorrect case used in the configuration.xml.


Happy to try and assist with this issue.

Hi Andrew.
I have the same issue, can you post the solution or steps to solve this issue?


In last days one customer with SCCM updates starts seeing this also.

Yes we have the same issue if we updated on the 1st Dec (we do a manual update each month or twice a month) so for some of us it appeared for the previous version number - something in this upgrade changed the command:

OfficeC2RClient.exe now has a parameter  /ChangeSetting updatesEnabled= False 16:

Would love to know how to change all these P.C.'s to be able to update again (even system admin doesn't have authority to enable)


I changed my configuration.xml file to remove the version number, then ran then ran setup.exe /configure configuration.xml and was able to update to 8730.2175 but still unable to update in the Office products.
  <Add OfficeClientEdition="32" Channel="Monthly">
Rather than   <Add OfficeClientEdition="32" Channel="Monthly" Version="16x">

I would check if one of or both regkeys are set:HKLM\software\policies\microsoft\office\16.0\common\officeupdate!enableautomaticupdates = 0HKLM\SOFTWARE\Microsoft\Office\ClickToRun\Configuration\UpdatesEnabled = False
If it is the case, close the Office applications, change the keys to 1/True and retest. If the issue is gone now and update is enabled, you must identify why these keys are set to 0/False. The first regkeys is controlled by Group Policies, the second is normally set during the setup or the user interface.

Both of those keys are set correctly for me...1/True and I still have the update issue.

Also have this issue following version 1711 8730.2122.  Nothing has changed in the environment, all registry settings are still enabled.  I question if this is something to do with channel name changes?  I have rebuilt C2R with latest ODT and redeployed but still no success :(


Same here Andrew. I downloaded a brand new version of the deployment tool, created a new xml document, uninstalled Office, and still no luck even with the latest 1712 build that came out a few days ago. I was really hoping that this month's feature release would include a fix for this.

I tweeted the link to this conversation to the Office team last week and they responded saying that this issue is on their radar. They didn't offer any other details, but at least they are aware. I hope they are working on this in earnest.

We are also experiencing the same issues. I found this page on Microsoft about switching from the Delayed Channel to Current Channel- Although we are setup for the Current Channel I figured it wouldn't hurt to see if maybe it updates some Registry Keys that were messed up. I created the batch file and ran it on a few computers with the issue and it seems to have fixed it. Just wanted to see what others thoughts are on this.

I tried running the fix on my computer and no change to the issue. Thank you for posting the fix that worked for you Lacy! Maybe that will help someone else in need.

For me, changing the REG key values did not work. However, switching from the deferred channel to the current channel, as Colton suggested, did work. Download the Easy Fix found here.

The Fix It For Me worked perfectly and it automatically started updating my Office install.