New add-in inventory report for Configuration Manager


Today a new report was released to the GitHub community site that allows you to collect and view an inventory of the Office Add-ins that are in use by the clients that you manage with System Center Configuration Manager (2012 R2 or later).

This report gathers the inventory of each Office add-in that is installed as well as the device that has it installed and the status (enabled, disabled) allowing you to determine which add-ins are in use as well as the impact based on the number of installations.  This report also provides a link to Microsoft's Office ProPlus Add-in Readiness report which you can view from



To get this new report, download it directly from GitHub at



4 Replies

Had to adjust the report files with report builder as they had a hard coded database name of CM_S01, but this works great!


found a slight problem here... It does not record addins that come from the microsoft store. This appears to only capture COM addins that are installed on the machine.


This makes it useless for me, because we had the setting turned on that people could install applications from the microsoft store and the end goal here is for me to figure out who has done that and what they are using. This does not appear to work for this purpose.

found this article now, and it shows you with one power shell command, how to extract this information from exchange and dump it into a CSV. even goes over how to create a nice pivot table chart!


Here is the command incase that page goes defunct:


Get-Mailbox -ResultSize Unlimited | ForEach-Object {Get-App -Mailbox $_.identity | Select-Object -Property DisplayName, Enabled, AppVersion | Export-Csv applist-export.csv -NoTypeInformation -Append}


you could easily tweak that to find which user has what plugin too.

I'm running into to same issue. I'm getting this message when trying to run the report "Invalid object name 'CM_S01.dbo.Custom_OfficeAddins_DATA'". I tried replacing "CM_S01" with my database name but I'm getting the same error. Did you have to replace more than just "CM_S01"? Thanks