Members information changed in Teams Admin centre does not come up in Teams

Occasional Contributor

I've added myself via Teams Admin centre as a member of a team to investigate some issues.

 

To my supprise, I appeared as an owner in TAC, but in the team itself I only came up as a member - with the rights of a member.

Even after restarting TEAMS, removing and re-adding myself and changing my rol several times (witch led to me being kicked out of the team after the switch from owner to member, why?), I still did not appear as owner in TEAMS, just only in TAC. (see attached screen shots - partly in Dutch.)

In the end, another team owner changed my role via TEAMS. This worked at last.

 

I have tried this with different TEAMS, and with different users (even our global admin). Sometimes the users don't even show up in TEAMS, but since changes sometimes take time, I'm willing to waite that one out.

 

Does anybody have a clue what is happening here?

 

 

1 Reply

I've reported a similar issue, which I thought was due to the specific configuration of my tenant/users. If you can reliably reproduce this, definitely open a support case.