Is there a way to disable second screen via GP or Reg after Outlook auto add's your account?

Copper Contributor



I am currently creating an image for a client, and they are requesting that Office O365 auto sign-in for each user. I have this working for all applications except Outlook. I am using the zeroconfigexchange registry key as well. 


Once Outlook is launched for the first time after sign in on the machine, it will auto load the email address, then you click next. It then prompts you if you'd like to add any other emails, and has the Outlook Mobile check box checked. In the screenshot below, I have unchecked it -- as it is not desired by the client. 




Is there any to completely get rid of this second screen via registry or group policy? If there is not, is there anyway to uncheck the check box via registry or group policy?




4 Replies


Here are my notes which worked for multiple customers on this..



ZeroConfigExchange = 1 (DWORD)


How to manually create additional Outlook 2016 profiles with ZeroConfigExchange in place


ZeroConfigExchange - Automating the Creation of an Outlook Profile for Exchange Accounts


When I performed this prior to profile being present on machine, Outlook was 100% silent.  This worked on first launch.. if I already had a profile on the machine it didn't work, I got Outlook profile prompt.  To troubleshoot I recommend you logon with another profile, use the "Advanced System Settings" feature from My computer to access User Profiles button and ensure the test account profile your using doesn't exist or delete it prior to test.


I also used process monitor to "trust and verify" that Outlook process checked and found this key on launch.


Finally, make sure you're following this process when creating a Windows "image" including Office 365 ProPlus.

Deploy Office 365 ProPlus as part of an operating system image


for Office O365, do we need to have single sign-on enabled?

@Heather_Kuhn Yes.  From what I'm seeing you should have SSO and Modern Authentication enabled. I have these configured in my lab (and it works).  This is likely your issue.

Perfect, thanks for a quick response! Going to test this now with those enabled