Teams created in Teams have Group Privacy: HiddenMembers

Copper Contributor

Since I could not create Class Teams from existing Groups (the option never appears), I tried creating the Teams in Teams first. This works, but now I can’t edit the Groups in the Admin Center because they have a Group Privacy setting that the Admin Center doesn’t seem to understand (HiddenMembers). The drop-down stays on “Loading” forever and it’s not possible to save any changes to the group.


I’ve tried editing in Teams admin center too, but it helpfully says:


We can't save the team. Please try again. If you continue to have problems, contact {SupportLink}.

Is there any way to fix this???

2 Replies

@SeanOS  I'm running into the exact same problem.  Did you ever figure out a solution?

@Greenhill4141Because of the inconsistency in privacy levels you can’t edit the group in the Admin Center, only in (I think) the Teams client. Also some features do not work if you are using the Teams client in Linux, so I have to set up a Windows 10 virtual machine to run the Windows Teams client and to run Windows PowerShell. There is a shifting array of PowerShell scripts that let you set some defaults for users that aren’t accessible anywhere else (like some Locale settings), but although there is a cross-platform version of PowerShell, the scripts are tightly integrated with other software that only exists in Windows 10. Figuring that out wasted a lot of my time and the documentation is terrible.


Managing a small number of users for a community-based language school, I’ve found the administrative overhead and sheer messiness of the system infuriating. I can’t imagine how this would scale well. On the other hand I haven’t had to change any group settings once they were set up, so the pain may be of a limited duration.