Copper Contributor

Hi everyone few days ago i buy one license of Microsoft 365 Business Basic for use Teams

I get this error when i try to connect Teams Admin center FAILED_TO_AUTO_DISCOVER_DOMAIN


In my dns server i put this records:

  • (cname)
  • (cname)
  • (srv)
  • (srv)

The Domain is in a good integrity check 

Any ideas?



15 Replies



Yes i try, but i get this error in powershell command


import-module Skypeonlineconnector ok

$sfbsession = New-csonlinesession : 

Get-CsOnlinePowerShellEndpoint : Remote server error: (404) Non Found.

In C:\Program Files\Common Files\Skype for Business

Online\Modules\Skypeonlineconnector\SkypeOnlineConnectorStartup.psm1:149 car:26

+ ... targetUri = Get-CsOnlinePowerShellEndpoint -TargetDomain $adminDomain ...

+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [Get-CsOnlinePowerShellEndpoint], WebException

    + FullyQualifiedErrorId : System.Net.WebException,Microsoft.Rtc.Management.OnlineConnector.GetPowerShellEndpointCm







Please can you share screen shots of your attempts in PowerShell?



Sorry I don't see anything in your reply?

@PeterRising Sorry!




What permission does your O365 account have?  Do you have Global Admin rights?

@PeterRising Yes my account is global admin and Teams Admin

I try, but i get the same error...



OK, give this a try and see if it lets you connect;


Import-Module SkypeOnlineConnector

$userCredential = Get-Credential

$sfbSession = New-CsOnlineSession -Credential $userCredential

Import-PSSession $sfbSession -AllowClobber -Verbose



Same error after this code

$sfbSession = New-CsOnlineSession -Credential $userCredential




Have you tried this on more than one computer?

@PeterRising @Melo1983 

The issue isn't restricted to Melo1983.  I'm having the same issue after creating a new tenant and adding that domain to the new tenant.  

I'm getting the same errors, and unable to manage Teams through Teams Admin console.
Tried from multiple machines, and same machines after reformat.

I do have an open case with Microsoft.  Waiting to hear back today after providing correlation token & tenant information.


My issue has been resolved by working through the ticketing system and getting a Microsoft O365 support engineer to help troubleshooting.  It had been a week, and my users were stuck in the "Provisioning" stage:

What worked for me:

I ran the following PowerShell as Admin:


Import-Module LyncOnlineConnector
$Session = New-CsOnlineSession –UserName ‘[your-global-admin]‘ –OverrideAdminDomain ‘[your-tenant-name]’
Import-PSSession $Session

Enable-CsOnlineSipDomain –Domain ‘[]‘
Disable-CsOnlineSipDomain –Domain ‘[]‘

Enable-CsOnlineSipDomain –Domain ‘[]‘


Paste the following into a browser:[]

(This initially didn't work for me.....I kept seeing an XML message which roughly translates to a 404).


# It may take some time to complete these changes on your tenant.  I left work at 5pm, and at 7am, everything was working. (including the URL).


For anyone else having this issue...

After trying many of the recommended things here and elsewhere over the net, I was able to finally resolve the issue by logging into the Teams portal by using the default "" Global Admin account rather than my personal global admin account.


Try it out!