Mesh public preview does not appear in Teams?

Brass Contributor

Hi all,

I have all the licences you need for the Public Preview. In Teams Administrator, the settings are set so that I can get previews.

I also see the app "Mesh Immesive Spaces" version 1.0.21., but I cannot add it. Neither in Classic Teams nor in New Teams.

Currently my tenant is in Western Europe.

Is it just not rolled out to us yet, or what else could it be?

15 Replies
The notes above suggest you've already gone through all the docs and troubleshooting steps. Please open support case with Teams (via Teams admin center) so the support team(s) can investigate further.
Thanks, I want to give you a like for this answer, but it don`t works ;).
So you get it here :thumbs_up:

@Holger_Duempelmann 
I wanted to get back to you that I've been TRYING to get Mesh immersive spaces to work in Teams since it was announced.

And it *wouldn't work*!! Until today and it doesn't quite work even then.

In Teams it should not even require a Premium license, just one of the Business or Enterprise licenses per user (which I have with E5).

I contacted someone inside Microsoft to try to nudge the preview team to see if they forgot to flip a switch or something- and wouldn't you know it, all of a sudden it WILL turn on now, today-- but it doesn't *quite* work....

 

One key is the version number for your Teams CLASSIC client (it ends in 28452- mine updated today, but I've *been* updating my client over and over since last week). 

A quick run down of what you need in the client

-- be sure you're running the desktop client

--be sure that client is CLASSIC. It won't work in new (LOL)

--be sure you have Public Preview enabled (the EA should be on your profile medallion)

--be sure you're on the correct version 1.6.00.28452

I am having other issues with it (like I can't get the environment to change, I can't get audio set up correctly because I can't add the app to Teams correctly, it doesn't have an add button the card)

 

Please let me know if you can get it to work now, because I really, really a public preview buddy to compare my settings and problems with. ;)

@CA Callahan 

 

Thank you for your patience and persistence working through those issues.


"I can't get the environment to change" - can you please submit Feedback from within the experience on being unable to change the environment?


"I can't get audio set up correctly because I can't add the app to Teams correctly, it doesn't have an add button the card" - I don't understand this feedback. There are suggestions in in https://support.microsoft.com/en-us/office/how-to-fix-app-audio-and-gpu-issues-for-immersive-spaces-... to debug audio issues. Do any of those help?

 

"be sure that client is CLASSIC. It won't work in new" - New Teams support is planned. (Avatars added New Teams support in September.) We'll let the community know when New Teams support is added.

@CA Callahan 

"I can't get the environment to change" - can you also check if any of the conditions in https://learn.microsoft.com/en-us/mesh/resources/immersive-spaces-known-issues#other-known-issues apply?

I was joining ad-hoc meetings in order to simply test the experience. I was trying other user accounts as well. No luck. Many meetings folks have are started, then participants are added or given a link. It would be a bummer if Immersive Spaces didn't work for them and they had to go through all the extra steps of creating a meeting right now, but with right now's time and date, and then add the users and invite them, in order to meet with the option to select the environment all involved preferred. Is this problem going to become a feature?
We covered the environment change in the other reply-- but the other two:

1) Classic is all that works right now. That it might work in the New version in the future is fine- there are other things that don't quite work in New right now as well, so it's not a surprise. BUT- if a previewer is in New Teams, and they do everything else right, but it fails anyway, well, that would be upsetting. Heck they might be in New because they thought it would be preferred by Microsoft.

2) I used that page about How-to-fix- app-audio to check my audio issues. *Everything* is right BUT the fact that Immersive Spaces is not available under the Teams page settings (not the in-the-meeting-settings everyone goes to because there are settings, and there are settings, and by the way, that document doesn't actually specify, but anyway), to check app permissions and turn on Media. The app isn't there. Now, I am an experienced admin- and I tried to add Mesh immersive spaces app to Teams for the users-- and the ADD button *isn't on the card that comes up when you select it to ADD. It can't be added- so I can't enable media under settings in Teams.

When I get back to my testing machines, I will edit this (if I can) with the pictures in situ, so you can see what I'm talking about. I am using my dev tenant to test this stuff (because I am not doing it in production, and I'll be playing with customizing worlds next), and I was reluctant to do in app feedback because it'll be from an onmicrosoft account. But I can submit preview feedback on all of this and wanted to a lot. Will the feedback coming from my tenant be acceptable or does it have to be a production work account- because I'm not going to beta test there. When I do feedback, is there anywhere I can go to see what's going on with it, like user voice or something? Is there an insider program or discord to join to do get more details about feedback than in this forum?

I appreciate you feedback because it feels like someone else cares about this like I do.
Thank you for the feedback.
That feedback has been heard and acknowledged from other parties too, but we don't have a committed date to change the behavior yet.

@CA Callahan 

"Will the feedback coming from my tenant be acceptable" - we're grateful for feedback from all sources. :) Mesh doesn't have a discord server or an insider program yet.

I tested a scheduled Teams Meeting, both attendees have Public Preview on. The person who first enters the meeting can see Immersive Space on the View menu, and click on it. They can do what I've been able to do with them alone in an ad-hoc meeting- hear the space, interact with interactables, move, but No, I could not change the environment, had the same error.

Further! The second person who enters the space, despite being on Public Preview, despite having been able to use Immersive Space when doing an ad-hoc meeting alone, *no longer has Immersive Space* on their view menu. I will continue to test... And will add pictures when I am able.
Thanks, then I'd like to grab pictures and keep dialoging here with you, AND I'll also add feedback in the app-- I can't remember if it allows pictures, which I really need to prove what I'm talking about in case I use words the tech support doesn't to describe things (and to prove what I am saying is what they see in the picture). Is that okay?
Thanks,
Short update from my side:
- I´m using since today the new Version 1.6.0028507 in Teams classic

in advance it does not work yet
I see the links in a template calendar entry in Teams, but nothing happens when you click on them.
You have to copy the link and then mesh is called correctly.
It works in Outlook, by the way.

But:
But, although I thought I had activated everything correctly, no EA setting appears in my profile since a few weeks (specifically since I have been using the new teams).
In fact, I always switch back and forth between the two teams versions.

I have looked again in the update guidelines of the Teams Admin Centre. The switch "Microsoft Controlled" was not activated as recommended. I have now done this and am curious to see what happens.

It can sometimes take a while until the policy is applied.
Holger- I am using version 1.6.0027573 Teams Classic. With this version, as of yesterday, I could get Immersive Spaces in Teams to work without the Premium license (as the documentation said it would). BUT I have run into problems.

As to New Teams, the documentation said for certain, immersive spaces will not work in New Teams, only Classic for right now.

I am curious how you are using Mesh without the public preview turned on for you Teams client.

Microsoft controlled for the Update Policy, simply means Microsoft will decide what the best Teams client version is. I set it to Teams classic because I want all the accounts in the tenant to be able to participate in the public preview.

I was told by someone to uninstall and reinstall Teams desktop client if it's not working properly, maybe you should uninstall Teams from the machine you're testing on, and reinstall Teams Classic, and try again with that. I have no issues having the EA come up in Teams- and I never go near New. I am suspecting going back and forth might be messing it up? Teams can be fragile on the best of days.
So, now much more seems to work, according to the settings in Teams-Admin-Center. Thank you for your tips, which have helped a lot.

The only thing that does not work yet:
The link to Mesh in a team appointment does not work yet.
Here you have to click separately on the right mouse button and select Open separately. At the moment, this is rather a minor issue.

I am not a developer, but a Business & Sales Consultant and I develop and sell ideas to customers. I know many comparable VR/AR collaboration solutions.

Here is my personal first impression of Mesh:
Of course Mesh at this stage still has far too little functionality compared to the other solutions and also the movements of the avatars need to become smarter. And I don't mean missing legs :-).
But Microsoft already manages to make a difference and offers things that I have not yet seen in other solutions.

- That is the selection of seating arrangements, which has really been solved super simply and well.

- There is very great emphasis on high-quality good-looking spaces right from the start. That certainly increases acceptance.

- Also, the integration into Teams is already pretty good and so already unique.

I won't write about the missing and desirable functions yet, because I'm sure they will be added quickly.

The only real criticism and limitation, in my opinion, is that there is no clear statement about whether accounts outside the tenant can be invited.

That would be a great, great pity if this did not happen, because it would mean that the use cases that have a very fast ROI for companies and are critical to the company cannot be realised. Examples are virtual trade fairs, VR in the sales process, HR assessment ....

And what surprises me!
Mesh was originally MixedReality. Now it is completely Virtual Reality.
Where is Augmented?
It is completely Virtual Reality. Fingers crossed Mixed Reality comes back again. I do appreciate the team focusing on VR only at this point, so they can progress it on that track. While I loved HL2 Mesh preview app, it isn't the priority today for me and in my cases with the Mesh. In the future I would love to see Mixed + Virtual Reality in the same space. Especially when thinking about the industrial metaverse, digital twins, education/learning scenarios.

Accounts outside of the tenant can't be invited. Now is the best to think use cases for Mesh that are inside the tenant. Of course there is a workaround: having a separate tenant where accounts are provisioned for users and everyone is using those. But that that requires more licenses, more management, more automation with account, more complexity and thus more money.