🚀 Exciting News: Microsoft Mesh is Now in Public Preview!


We are thrilled to introduce Microsoft Mesh, now in public preview, a revolutionary 3D immersive experience that is transforming the way we work and connect virtually. Mesh is here to make your virtual meetings and events feel more like genuine face-to-face interactions.


Please visit our blog for more information regarding Mesh announcement Building immersive experiences with Microsoft Mesh.


Here are some of the resources we think you’ll find most useful:

Microsoft Mesh opens a new realm of possibilities for remote collaboration and immersive experiences. Join us on this exciting journey of creativity, connection, and innovation.



Milena Paumen 

6 Replies

@Milena_Paumen very exciting times!

I just deployed my first Quest VR app on my Quest2 headset using Unity the other day, first time. I'm hoping this is a perfect and easy transition into Mesh, as I am a Teams administrator and super user over the years and curious how the VR/XR and hybrid meeting experiences will work. Thanks!

@Milena_Paumen  how do i login to mesh? it doen't allow me to use a personal account


Milena, I saw announcements this weekend that Mesh was being released for Quest. I have a quest 2 and 3, and can't get the Microsoft Mesh (App Lab) loaded. I'm able to sign in with /devicelogin and using my M365 account, but then get an error.

Dialog box title. Error:
Unexpected startup failure. Please restart and try again.

I have uninstalled/reinstalled the app, logged out/on again, and rebooted quest headset, no luck just same error on launch now. It did prompt and let me logon, so the message was after I'd logged on but can't proceed any further. Help?Image.jpeg

Hello there, tried again and still getting the same error. Can logon successfully, have M365 E3 and appropriate licenses provisioned. Is there anyone on Microsoft Mesh team that is posting or engaged anywhere with community, like developers on X/reddit/discord or other communities? There are pockets in MS that are really good at community engagement, and then others where you see a blog post and no activity for 8 months and wonder who's driving this? Anyone know, or can speak to this?
Same issue here: "unexpected startup failure". Licence checked, device login works, but the app doesn't start.
It requires a work account and a Teams Premium license.