Vision AI Devkit wifi issue


The device was working earlier today and I was able to load an image to the device.

I was working through the VS code samples and must have ruined something.


Now the device is showing 3 amber lights, I can't connect to its wifi network, and it won't connect to the external network. Also, docker daemon won't start up.

Adb over USB is working OK.

I tried 'adb reboot' but that didn't help.


(base) C:\WINDOWS\system32>adb devices
List of devices attached
f6bbeb6f        device

(base) C:\WINDOWS\system32>adb shell ifconfig wlan0
ifconfig: wlan0: error fetching interface information: Device not found

(base) C:\WINDOWS\system32>adb shell docker images
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
4 Replies

Hi @avivhu What firmware version are you running on the device?

@jkubicka Using Version v0.2680_Perf.
My problem was solved by reflashing the firmware, same version.

@avivhu where did you get the firmware? Can you share it? I'm stuck in a very similar situation

@_riki_ I got it through an inside channel at Microsoft so I'm not permitted to share it. I hope a dev is reading this can can help you with resetting the firmware!