Issue with Vision AI Developer Kit

Occasional Contributor



I'm facing trouble with my Vision AI Developer Kit, I'm stuck at this point for hours, how long does it usually take? any solutions?

Thanks in advance.

20 Replies

@Diaaalaa it should take a couple of minutes max, not hours.


Are you taking the camera into use for the first time, resetting it or re-configuring WiFi?


There is a known issue where the WiFi reconfiguration doesn't work reliably.


Do you have platform tools installed? Please check with adb shell ping that you camera is still connected to internet. Also, what color the leds are in the camera and are they blinking?

@Jussi Niemela Thank you for your response.
It was the first time. I've tried connecting it once again to Azure as an IoT device, it said that my camera was already set up, so I tired resetting it.
Now once again it is downloading Azure IoT Edge runtime, for almost an hour now.
I have the platform tool installed.
Currently the LEDs are blinking in amber.
Does my internet connection has to be up to a certain limit? It's almost 13Mbps download speed.
What can I do?

@Jussi Niemela 

It's finally set now, I disconnected from the camera and connected to the same wifi my camera is connected to, but the live stream won't work.


best response confirmed by Deleted



Thanks for the update. If the web pages doesn't open at all it typically indicates that the devices are not in the same network after all. Do you happen to have physical cable attached to your laptop? If yes, you'll need to disconnect and only use WiFi. I have seen that in those cases it still defaults to physical connection. The easiest way to get a picture out from the device is to use HDMI display. Do you have a chance to do that? It needs to be native HDMI, most adapters don't work.


Can you do "adb shell docker ps" with ADB and confirm that all four default modules are running? edgeAgent, edgeHub, AIVisionDevKitGetStartedModule and WebStreamModule

@Jussi Niemela I just made sure that my laptop is connected to the same wifi as my camera.
My laptop is connected to wifi only, the only cable attached to it is the camera's data and power cable.

I don't have an HDMI monitor at the moment, but I tried my TV screen and this is what it showed. 

a2.jpg It's blinking in amber btw. (does that mean it's offline?)

Regarding the four modules, this is what it shows.





Thanks for the additional information. Your TV screen will work and show the stream from the camera. If it shows the grey flower background it indicates that to the connection to the display works, but the AI model is not running. When the kit is set up correctly it'll show three solid green leds. 


Are you using this at home or in an office environment? Is your kit grey, not white (is this an officially purchased kit of something else?)?


Can you run following ADB commands:

-adb shell cat /etc/version to confirm the firmware version that you have in the kit

-adb shell ping to check if the kit actually has an internet connection.


As you can see from the Azure screen shot none of the modules have been reported by the device so I am thinking there is an issue with the internet connectivity.


I think you'll need to start over and press the power button for 5 seconds so that the leds start to blink, connect to the devices AP and select "reset the device". But before that let's figure out the network connectivity.

@Jussi Niemela That's good news about my TV screen.:smile:

I'm using it at home. And it's the official Vision AI Developer Kit. I purchased it from


adb version version.PNG

adb shell ping bing.PNG



It seems network connection works, but for some reason the modules are not getting downloaded from the cloud or they are not running.


You can try following things:

-adb reboot - reboots the device.

-adb shell systemctl restart docker - to restart dockers

-adb shell docker logs -f edgeAgent - and provide the output to this discussion. It should tell what prevents the edgeAgent from running.


@Jussi Niemela It's now blinking in green and this is the outcome.docker log.PNG

I pressed the power button for 5 secs for the access point, and it's now blinking in amber again.



when it's blinking amber (or any color) it runs its own access point and you can log in to the device.
Did you do that and go through the device setup experience again? I would recommend doing it, if you did try following commands. It looks like you don't have docker containers in your device, so you can try to pull them manually.

adb shell docker container ls -a - list the containers in your camera. You can try to pull manually the ones that you don't have:

adb shell docker pull

adb shell docker pull

adb shell docker pull

adb shell docker pull


You may try the commands I provided earlier after that. At the end of the OOBE (Out of Box Experience) the device should have these four docker containers (modules) in the device. 

@Jussi Niemela This is the outcome. iot hub.PNG



Sorry, there was a typo in the spelling of Microsoft:

adb shell docker pull


Once you have confirmed that edgeHub docker is also in place then the question becomes to why they are not running. Ideally you should have solid green colors that indicates that all the containers are running. Then you should also see the picture from your display.

-adb shell docker ps shows the status of the running dockers.

If things don't start to work you can also try these again. But give them some time, don't run them all at once. After the two first ones you can check "docker ps" again. 

-adb reboot - reboots the device.

-adb shell docker logs -f edgeAgent - show the logs of edgeAgent container and should provide help in troubleshooting

-adb shell systemctl restart docker - to restart dockers


@Jussi Niemela before.PNG

Something was wrong with adb shell docker pull , so i restarted the dockers. 


The 4 modules appear to be running, but there's still an issue with adb shell docker logs -f edgeAgent.



The dockers are only running if adb shell docker ps shows them


Can you do:

adb shell docker container list -a

It lists the docker containers in your device. They should be based on the docker pull commands (by the way using docker pull is a exception, normally they should be downloaded automatically)


This is so weird. I'll ask around if someone knows what's going on. 


I would recommend pressing the power button for 5 seconds and doing the whole device setup again. When the leds are flashing you can log in to the device, open in your browser and do the OOBE (Out of Box Experience) again. If you are prompted with an option to either reset the camera or reconfigure WiFi, please select "reset camera" and follow the instructions.

@Jussi Niemela I reset the camera and the same issue is still going on. It says "Image is up to date" for the four modules and "adb shell docker logs -f edgeAgent" 's outcome is still the following:
Error: No such container: edgeAgent



Have you checked your Azure IoT Hub to see if you have created a device there? What does it say about the modules? -> IoT Hub -> IoT Edge (from the side menu).


If you access the actual device what does this view look like to you?


@Jussi Niemela 


My problems are similar to Diaaala's problems. I tried one of your proposals and got the following notice:







You shouldn't need to typically pull docker containers yourself, it's a special case kind of thing if your containers don't get automatically pulled. Have you ever gotten the device work properly?


Can you please do:

adb shell ping to make sure that your device has internet connection.


adb shell docker container ls -a to list all the containers you currently have in your camera