SOLVED

IoT edge package on linux

New Contributor

I am having issues installing the IoT edge runtime on a linux debian device. I followed the microsoft docs guide to install IoT Edge runtime and managed to install the "packages-microsoft-prod.deb". However, when I tried to run "sudo apt-get install aziot-edge defender-iot-micro-agent-edge", it gave me an error that both packages were not located. Could it be that I am still missing a resource?

1 Reply
best response confirmed by Tiaan-S (New Contributor)
Solution

@Tiaan-S the instructions are currently for arm32v7 devices.  If you're on an x86_64 or arm64 device then you may encounter the error below because the respective packages for those architectures have not been published to packages.microsoft.com.