Home

Factory reset Vision AI Developer kit does not work

Highlighted
New Contributor

Hi,

I am trying to do factory reset of vision-ai-developer-kit. But clicking twice on power button does not work!

Initially I tried connecting the device to wifi and I am trying to reset my wifi settings now. The camera always gets connected to wifi (green led lights on) but no IoT connectivity. 

 

I tried `http://XX.XX.XX.XX:3000` to see the stream but not able to connect. I tried pinging but I get to see Request timed out. as response. Also via vls player with rtsp (`rtsp://XX.XX.XX.XX:8900/live`)

 

I tried with adb but still not able to connect with the device adb connect `XX.XX.XX.XX:3000 ` cannot connect to `XX.XX.XX:3000` A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)

Can someone please let me know how to do proceed or do factory reset? Thanks.

Any help would be really helpful in setting up this kit quickly. Thanks.

 

Regards

Lavi

 

23 Replies
Highlighted

@Lavi2019 To factory reset the Vision AI Dev Kit, hold the button on the back of the device down for 12 seconds or longer. 

Highlighted

@Lavi2019 

 

You can press the power button for 5 seconds (give or take) and get the device back to AP mode meaning that then you can login to devices's WiFi. When the device is in AP mode it's flashing the colors. It opens http://setupaicamera.ms page. As you have done the initial setup already it provides you with two options 1) Reset the device and run out-of-box experience again 2) just reconfigure the WiFi. Note that there is a known issue with device colors not always being correct when resetting the device (https://github.com/microsoft/vision-ai-developer-kit/issues/234)

 

The streaming should work as long as your laptop is connected to the same network than the camera (I have seen it work also with your laptop still being connected to the camera). In case it doesn't you can start troubleshooting with adb and first check that the streaming module is running by doing "adb shell docker ps".

 

Here is a little bit more information regarding streaming with media player:

https://azure.github.io/Vision-AI-DevKit-Pages/docs/RTSP_stream/

Highlighted
I cannot get the device to reset even using these instructions. The device is now just blinking red, intermittently, not consistently. I've tried to factory reset, and the steps above and cannot get back into wifi mode to access tools.
Highlighted
Hi, are you still running into this issue?
Highlighted

@Lavi2019Any updates? I got the same problem, i cant see any stream... 

Highlighted

@MarcoWirtl what firmware version are you running? Try holding/pressing the button on the back for 5+ seconds to factory reset the device and set up the device again.

 

Also, what do you see for the web browser webstream?

Highlighted
Highlighted

@Lavi2019 

 

Hey Guys,

 

- Devices is attached

- Current Version (Shipping version) : v0.4940_Perf

- Is connected to WIFI and Azure IoT Hub

- All 4 Modules are on the camera (adb shell docker ps)

 

 

Running on Windows PC i copy the "FastbootUpgrade_v6_5.bat" + "VisionAIDevKit_InstallCheck.bat" File from the FW_UpgradeScript_Windows_v6_5 in the v0.5330_Perf Folder (where or what is the flat images folde in the PDF mentioned? / folder that contains the actual firmware files?)

--> see Screenshot 1

 

In this case when i run the FastbootUpgrade.bat i get an error (../v0.5330_Perf/abl.elf is missing(X) --> Screenshot 2)

 

Can anyone help?

 

 

 

 

Highlighted

@MarcoWirtl 

 

If you run the scripts in the same folder than where the firmware is you'll need to change this row in Fastboot script to look like this:

clipboard_image_1.png

 

The script structure keeps changing between the firmware updates so the instructions might unfortunately be outdated

Highlighted

@Jussi Niemela 

 

Changed the .bat file like this (also tried fw_path= BLANK): 

FastbootScript.PNG

When i run i got the same error:

 

Error.PNG

 

 

My folder looks like this:

FirmwareFolder.PNG

 

Also settedmy enviroment var to the oath of my plattform tools:

 

EnvVariable.PNG

 

So can you help me?

 

 

Highlighted

@Jussi Niemela 

 

Info: My machine is a windows machine!!

 

When i run the Linux Script (just intuitation because the Kit is running Yocta Linux) instead it finds the abl.elf file and start, it runs until the Install Check Script and prints:

 

ErrorLinuxPNG.PNG

It stucks on this point!

 

Highlighted

@MarcoWirtl 

 

I honestly don't know where the problem lies. I changed the abl.elf file name in the script to abl.elves and got the same error starting ./abl which indicates that you configuration is correct. When I changed the script back to search to abl.elf it works. 

clipboard_image_0.png

 

The only thing I can think of is that you are not running it in the v.05330_Perf folder but in the folder where the script is originally located. But I am sure you've checked that. Just to out rule that can you take a screenshot where your C: path is visible when you execute FastbootUpgrade_v6_5.bat?

Highlighted

@MarcoWirtl 

 

I've never done this on Linux, but you could try to comment out the "rm device.log" from the upgrade script? It seems to only be used to check if the device is connected

Highlighted

@Jussi Niemela 

 

i'm running it in the  v.05330_Perf folder!

 

Befor i start any script the camera is connected to WIFI and IoT Hub and all 4 docker containers are running.

 

Workflow Nr.1:

1. Open the  v.05330_Perf folder in Explorer

2. Right Click on FastbootUpgrade.bat 

3.  execute as administrator

4.  Got this error (Here the screenshot where the C path is visible): 

RightClick_Error.PNG

 

 

Workflow Nr 2 (See all in the following Screenshot):

 

1. Open CMD as a administrator

2. cd to the v.05330_Perf folder

3. start the .bat 

4. Upgrade Fail  

 

clipboard_image_0.png

Highlighted

@MarcoWirtl 

 

So it actually goes further from the command line and doesn't complain about the abl.elf. What happens in the scenario is that the device reboots to bootloader mode. It seems you press "any key to continue" before USB recognizes the device again. If you have sound on in your computer you should hear a sounds when the USB disconnects (device reboots) and then another sound when USB founds the device again. It's safe to continue after that. 

 

Having said that I have recently seen a case where the device is never recognized again. I asked developers about it and only root cause we know is that "it's USB cables fault" (and it's not 100%). So I'd recommend to try again and wait for the USB to recognize the device again after the reboot. If that doesn't happen try switching the USB cable if you have options.

Highlighted

@Jussi Niemela 

 

So the starting point is that my devices is connected to WIFI and IoT Hub (Green LED Lights)

 

I'm running the .bat script.

 

After that my device disconnects (Sound appears)

 

USB connects again (Sound appears)

 

The device LED's are red now

 

Got the error message: ping command is wrong

 

Stocking at this screen:

PingError.PNG

 

After pressing any key:

 

NoDevices.PNG

 

Like you said no devices recognized...

 

 

When i reboot the device with the POWER Button --> disconnected Sound appears and connected sound again.

After a couple of seconds adb devices works again... & LED's are green

 

I will get an other USB and check it again.

 

 

Highlighted

I'd like to check with you for 2 things.

1. Are you using the inbox USB-c cable?

2. You script should be located "PEABODY_QCS603_LE_r37-v0.5330_Perf\PEABODY_QCS603_LE_r37-v0.5330_Perf\FW_UpgradeScript_Windows_v6_5\FastbootUpgrade_v6_5.bat" give that you are using Windows device. Please check if there is a line @SET fw_path=../v0.5330_Perf/ in FastbootUpgrade_v6_5.bat. If not, please add it after @echo "Check fastboot files..." or download the firmware again from Altek's site as you did. There was a minor bug in the script and we updated it earlier.

Highlighted

@devinwong 

 

Yes i'm using the shipping USB.

 

Tried it like you said:

 

My .bat file:

 

clipboard_image_0.png

 

 

Location:

 

clipboard_image_1.png

 

Error:

 

abl.elf is missing

 

 

Already tried a lot... nothing works

 

 

Highlighted

@MarcoWirtl  I found the reason. There is a mistake in the Altek AI Camera Reflash Firmware.pdf that you may have referred to. Please do not copy/paste the folder FW_UpgradeScript_Windows_v6_5 into v0.5330_Perf. Just leave it as is. Run the bat file directly. The bat file should be located at "\PEABODY_QCS603_LE_r37-v0.5330_Perf\PEABODY_QCS603_LE_r37-v0.5330_Perf\FW_UpgradeScript_Windows_v6_5\FastbootUpgrade_v6_5.bat"

Highlighted

@devinwong 

 

Did it abl.elf still is missing.

 

When i hardcode the complete path

 

it finds the fastboot files and reboots the kit but stuck here:

 

clipboard_image_0.png

 

The USB sound appears: 1) disconnected few sec. later 2) connected 

 

The LED's are solid red after adb reboot runs

 

After pressing any key:

 

clipboard_image_2.png

 

 

Highlighted

@MarcoWirtl 

The abl.elf not found issue was had nothing to do with device.

And this new issue has nothing to do with files now.

We saw very few reports on this before.

As far as I know, the users tried the following 2 things.

-use the inbox USB-C cable as you do now.

-when it asks to press any key after adb reboot bootloader, do not press it immediately. Try to press any key after 1 minutes or even longer (15 minutes).

 

 

Highlighted

@devinwong 

 

Updated my firmware.

 

My fastboot driver didn't work.

 

Tried it on a friends mac --> updated

 

Thanks!

Highlighted

@MarcoWirtl  - did updating the firmware fix your issue?  I have the same issue.  

Related Conversations