Resolved: Known Issue with importing Windows Autopilot devices using Order ID in CSV

Published May 21 2019 11:19 AM 22.9K Views

Update 5/24/19: Fixed! We still recommend using Group Tag instead of Order ID moving forward but for now Order ID has been added back in the backend.


We recently made a change in how you can import Windows Autopilot devices from a .csv file.
In the 1905 service update to Intune, the option for Order ID was changed to Group Tag instead. As a result, Order ID tag does not get set when importing devices through AutoPilot using a .csv and is not populated for imported devices. There are, however, no errors notifications shown in the console.


AP Group tag.jpg

We are working on fixing this in the service and will also shortly be adding this to the What's New page. Until then, as a workaround, if you are importing devices using OrderID, you can change the column in the .csv file used for importing from “OrderID” to “Group Tag”.

Occasional Contributor

You guys need to get better about communicating these type of 'breaking' changes ahead of time.

Regular Contributor
But in the query in a (dynamic) AutoPilot group we still need to use orderid....... (device.devicePhysicalIds -any _ -eq "[OrderID]:179887111881") Confusing!
New Contributor

36 hours later, trying to import the CSV multiple times a day, i finally found this Post.... 


And I see it was mentioned on but not on

Maybe a good time to check why there is a difference here, the dutch page shows may 6th changes and the english/us page the may 20th.


Regular Contributor

@Patrick Stalman Dutch version is always old, always check the en-us version which is up dated first

Senior Member

It looks like the workaround mentioned above does not work. When I change the column name from "OrderID" to "Group Tag" devices get imported in Autopilot but the Group Tag is not imported. So dynamic groupmemberships do not get updated and automatic assignment of implementation profiles fails. Someone had any luck importing the "Group Tag" into Autopilot?

Regular Contributor

@TjitzeVeenstra Yes used it Yesterday with the group tag without any issues.

Senior Member

@Peter Klapwijk What did you change in the CSV-file? Only the header? This is what I use as the header to identify the columns:

Device Serial Number,Windows Product ID,Hardware Hash,Group Tag.


I also tried using the following header:

Serial Number,Windows Product ID,Hardware Hash,Group Tag

Devices still do not get the Group Tag applied.


Is you header the same as mine? What value does your Group Tag have? An example of a value for the Group Tag we use is FCROC_PersoonlijkeLaptops.

Regular Contributor




This is my header:
Device Serial Number,Windows Product ID,Hardware Hash,Group Tag


Looks the same as your original header.


And I just used a combination of a few letters and numbers


Senior Member

@Peter Klapwijk Thats the same header. I tried it again with another Group Tap (some letters and numbers and left out the underscore). Still no Group Tag in Autopilot.


Just out of the blue I had the idea to try to import the devices from a different browser and OS. For some stupid reason the devices get imported with the Group Tag applied! Before the change I always used my MacBook with Safari to import the devices into Autopilot. It always worked until now.....

@Patrick Stalman we'll check with our documentation team to figure out why there's a lag for updating the Dutch page.

@Jan Gutjahr we've given our engineering team that feedabck.

This issue has now been fixed. Let us know if you still have any issues!

Occasional Contributor
This is still broken. I try Group Tag and OrderID on import, both of them didnt work.
Senior Member

@Sven Jansen, It works for me, as long as I do not use Safari on my Mac to import. Just a few minutes ago I used Chrome on Windows to import some devices with Group Tag in the header. The import was successful. Maybe you can check the text encoding of your CSV-file? On Windows the file is encoded as Unicode. On my Mac I saw that the file was encodes as UTF-16. Maybe this is causing the problem?

Occasional Contributor
@TjitzeVeenstra i created the csv with Get-WindowsAutoPilotInfo and edit the file with np++, i compared my new and past files, all have the same encoding. The file gets imported but the tag is missing. i tried both variations Device Serial Number,Windows Product ID,Hardware Hash,Group Tag Serial,,VeryLongHash,MyGroupName In the past i didnt bother extending the header, i just added the OrderID value at the end. Device Serial Number,Windows Product ID,Hardware Hash Serial,,VeryLongHash,MyGroupName
Occasional Contributor
Sorry formatting fails me and no way to edit my post :(
New Contributor

Do you always use the NP++ to edit the file, if yes can you try to use another edit tool and try it again?

I can succesfully add the Group Tag when I import 1 or more machines. And I can also see the machines receiving the right (device driven) autopilot profile ,so I am pretty sure the machine is also in available in the Dynamic AD group (that still checks on Order ID).

Occasional Contributor
We solved it by adding another placeholder between hash and grouptag for the OrderID like this: Serial Number,Windows Product ID,Hardware Hash,,GroupTag
Regular Visitor

if we are using group tag instead of OrderID, what should be mentioned as dynamic membership rules? as mentioned earlier we are still using OrderID tag while creating Dynamic membership rules.

Occasional Visitor

When Autopilot registrations were done via the MS Store for Business the groups were easy to add (at the time of import) now seemingly the tags need to be added in the CSV file, which i have working but seriously - another manual step in a process that is all about automation.  And what happens if you tag it wrong?  I see no way of changing the group tag once it's been set.  Considering may of us are using this to create dynamic groups it seems sensible that this would be something you can change.  I mirror the comment from Jan Gutjahr the communications on changes for these systems need to be clearer.  I raised a case with MS Support as i was unable to register a device using autopilot,(still unresolved) and neither of the two support tech i have spoken to wee even aware you could register devices through MS Store for business.  I'm still confused about whether i should even be using that anymore or not and if so what for?

Occasional Visitor

oh in case i'm alone in my use of MSFT Store for business registrations - it is a thing, honestly, look here's an ms page on it from last year:

Occasional Contributor

@Woodsta we stopped using the Store for Business for Intune registrations a long time ago after MS released guidance on this. That guidance mentions that you should really be using only the Intune portal from now on:

They should probably update the documentation that you linked to above to also include that....

Regular Visitor

Just tested an import using OrderID but it arrived with a group tag of n/a


Although 'Group Tag' as a field name will import just fine I can't seem to get this to work in the dynamic group rule, presumably because of the space in Group Tag.


Has anyone found a way around this? Tried putting quotes around it but this does not work.


Currently using: (device.devicePhysicalIds -any _ -eq "[OrderID]:MyDeviceTag")


Need to use something like: (device.devicePhysicalIds -any _ -eq "[Group Tag]:MyDeviceTag") but this doesn't work

Senior Member

@Jason Smith, I am using this for my dynamic group rule:


(device.devicePhysicalIds -any _ -eq "[OrderID]:MyGroupTag") which is just how it was before the Group Tag was introduced. It works just fine. If I am correct only the Group Tag has to be used when importing devices into Autopilot. The OrderID field is stille used in AAD.

Regular Visitor

@Jason Smith 


i am still importing csv with this format:


Device Serial Number,Windows Product ID,Hardware Hash,Order ID.  and it works well. as mentioned by @TjitzeVeenstra dynamic security group can be defined with exactly same as before. so in my case im mentioning "(device.devicePhysicalIds -any _ -eq "[OrderID]:GroupTag/OrderID")"

Senior Member

Just spent multiple hours trying to figure out what was wrong with my autopilot environment, then stumbled across this post. Future changes like this need to be clearly documented.




The following script works. 

Install-Script -Name Upload-WindowsAutopilotDeviceInfo

Upload-WindowsAutopilotDeviceInfo.ps1 -TenantName "" -OrderIdentifier "AADUserDriven" -Verbose

Occasional Contributor
Is that whole Autopilot thing broken? first i thought the OrderID thing is not longer working because grouping autopilot devices stopped working, then i used Graph Explorer to check what OrderID the device object has, but all Autopilot attributes are missing but device got enrolled by Autopilot by myself? This is how phyiscalIds looks for all new Autopilot enrolled devices. "physicalIds": [ "[USER-GID]:xxxxxxx", "[GID]:g:xxxxxxx", "[USER-HWID]:xxxxxxx", "[HWID]:h:xxxxxxx" ], existing devices has entrys like "physicalIds": [ "[USER-HWID]:XXXXX", "[USER-GID]:XXXXX", "[GID]:g:XXXXX", "[OrderId]:MyTag", "[ZTDID]:XXXXX", "[HWID]:h:XXXXX" ], In Intune blade i can see that devices are autopilot devices and got the right profile applied.
Occasional Contributor
I found the issue. If you import a new system has via csv it instantly creates a new azure ad device with the serial number as devicename. If for some reason this azure ad device gets deleted by hand, autopilot still enrolls the device and created a new azure ad object but does not attach any ztd attributes to the device. So you still have autopilot experience but an device object missing the information it is autopilot.

Sven, What is the PowerShell Intune Graph(Get-DeviceManagement ??? ) cmdlet you are using to get the AutoPilot information? How are you getting the AutoPilot OrderID/GroupTag information? 

Occasional Contributor
You can use to browse your devices. You have to enable several permission in Graph Explorer, i cant remember if this was enough,
Version history
Last update:
‎Feb 01 2021 02:06 PM
Updated by: