Office 365: Outlook and Teams, Trusted Platform Module and password request at every start

%3CLINGO-SUB%20id%3D%22lingo-sub-1700958%22%20slang%3D%22en-US%22%3EOffice%20365%3A%20Outlook%20and%20Teams%2C%20Trusted%20Platform%20Module%20and%20password%20request%20at%20every%20start%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1700958%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20everyone.%3CBR%20%2F%3Eone%20of%20my%20customers%20with%20%3CSTRONG%3EMicrosoft%20365%20Business%20Standard%20(ex%20Office%20365%20Business%20Premium)%3C%2FSTRONG%3E%20regularly%20upgraded%20Windows%2010%20to%20version%202004%20on%20an%20Acer%20TMP645-SG-77DV%20laptop%20in%20August.%3CBR%20%2F%3EAfter%20completing%20it%2C%20%3CSTRONG%3ETeams%20and%20Outlook%2C%20at%20each%20start-up%2C%20ask%20for%20all%20the%20access%20passwords%20for%20the%20user%20registered%20(Teams)%20and%20for%20each%20configured%20e-mail%20box%20(Outlook).%3C%2FSTRONG%3E%3CBR%20%2F%3EAlso%20selecting%20the%20option%20of%20remembering%20passwords%20each%20time.%20(attached%20image)%3C%2FP%3E%3CP%3EThe%20user%20used%20is%20an%20administrator%20user%20of%20the%20machine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAn%20error%20message%20also%20appears%3A%20%22%3CSTRONG%3EThe%20Trusted%20Platform%20Module%20of%20the%20computer%20did%20not%20work%20properly.%20...%20Error%20code%2080090016.%20Other%20information%3A%20%3CA%20href%3D%22http%3A%2F%2Fwww.microsoft.com%2Fwarmerror%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ewww.microsoft.com%2Fwarmerror%3C%2FA%3E%3C%2FSTRONG%3E%22%20and%20below%20%22S%3CSTRONG%3Eerver%20message%3A%20Keyset%20does%20not%20exist.%3C%2FSTRONG%3E%20%22%20(attached%20image)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20changes%20have%20been%20made%20to%20the%20hardware%20of%20the%20PC%2C%20that%20worked%20regularly%20with%20these%20applications%20before%20the%20update.%3CBR%20%2F%3EAfter%20all%2C%20once%20the%20authentication%20is%20done%2C%20everything%20works%20regularly%20for%20the%20whole%20day.%3CBR%20%2F%3EThe%20same%20situation%20also%20occurred%20on%20a%20PC%20belonging%20to%20a%20colleague%20of%20this%20customer.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDuring%20a%20remote%20assistance%20session%20I%20had%20Malwarebytes%20disabled%2C%20turned%20off%20the%20PC%20and%20turned%20it%20back%20on.%26nbsp%3BThe%20first%20time%20it%20didn't%20ask%20for%20anything%2C%20then%20everything%20went%20back%20as%20before.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20studied%20the%20problem%3A%20it%20seems%20not%20to%20be%20solved%20with%20a%20reinstallation%20of%20the%20applications.%3CBR%20%2F%3EMore%20important%2C%20it%20is%20not%20very%20clear%20what%20it%20comes%20from.%3C%2FP%3E%3CP%3EIt%20is%20a%20PC%20in%20production%2C%20so%20I%20DO%20NOT%20want%20to%20do%20%22invasive%22%20operations.%3CBR%20%2F%3EWe%20will%20do%20a%20complete%20image%20backup%20(which%20I%20will%20check%20personally%20before)%2C%20but%20even%20if%20the%20thirty%20years%20of%20experience%20and%20I%20have%20the%20culture%20to%20touch%20the%20registry%20and%20so%20on%2C%20I%20like%20very%20much%20before%20understand%20what's%20wrong%2C%20what%20to%20do%20and%20why.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFinally%3A%20is%20this%20a%20Windows%2010%20and%20Updates%20issue%20or%20Office%20365%3F%3CBR%20%2F%3ESince%20the%20errors%20appear%20ONLY%20in%20Teams%20and%20Outlook%2C%20I%20put%20this%20question%20under%20this%20community%20branch%20(Outlook%20primary%20topic%2C%20Windows%2010%20secondary)%2C%20but%20I%20have%20doubts%20about%20the%20true%20source%20of%20the%20problem.%3CBR%20%2F%3ESo%2C%20if%20I%20haven't%20chosen%20the%20right%20category%20...%20sorry%2C%20it's%20not%20even%20the%20wrong%20one%3A%20now%20the%20answer%20matters%2C%20and%20I%20sincerely%20thank%20those%20who%20have%20the%20time%20and%20desire%20to%20write%20any%20idea%20that%20may%20come%20to%20the%20mind%20of%20the%20reader.%3C%2FP%3E%3CP%3EFor%20my%20part%2C%20I%20will%20post%20the%20solution%20found%20(optimism!)%20For%20others%20who%20need%20it.%3C%2FP%3E%3CP%3EThank%20you%20very%20very%20much.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1700958%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAuthentication%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIdentity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESecurity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%2010%20App%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%2010%20Upgrade%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hello everyone.
one of my customers with Microsoft 365 Business Standard (ex Office 365 Business Premium) regularly upgraded Windows 10 to version 2004 on an Acer TMP645-SG-77DV laptop in August.
After completing it, Teams and Outlook, at each start-up, ask for all the access passwords for the user registered (Teams) and for each configured e-mail box (Outlook).
Also selecting the option of remembering passwords each time. (attached image)

The user used is an administrator user of the machine.

 

An error message also appears: "The Trusted Platform Module of the computer did not work properly. ... Error code 80090016. Other information: www.microsoft.com/warmerror" and below "Server message: Keyset does not exist. " (attached image)

 

No changes have been made to the hardware of the PC, that worked regularly with these applications before the update.
After all, once the authentication is done, everything works regularly for the whole day.
The same situation also occurred on a PC belonging to a colleague of this customer.

 

During a remote assistance session I had Malwarebytes disabled, turned off the PC and turned it back on. The first time it didn't ask for anything, then everything went back as before.

 

I have studied the problem: it seems not to be solved with a reinstallation of the applications.
More important, it is not very clear what it comes from.

It is a PC in production, so I DO NOT want to do "invasive" operations.
We will do a complete image backup (which I will check personally before), but even if the thirty years of experience and I have the culture to touch the registry and so on, I like very much before understand what's wrong, what to do and why.

 

Finally: is this a Windows 10 and Updates issue or Office 365?
Since the errors appear ONLY in Teams and Outlook, I put this question under this community branch (Outlook primary topic, Windows 10 secondary), but I have doubts about the true source of the problem.
So, if I haven't chosen the right category ... sorry, it's not even the wrong one: now the answer matters, and I sincerely thank those who have the time and desire to write any idea that may come to the mind of the reader.

For my part, I will post the solution found (optimism!) For others who need it.

Thank you very very much.

 

0 Replies