Home

Configuring iOS 12 for O365 Exchange using MFA (OAuth)

%3CLINGO-SUB%20id%3D%22lingo-sub-227194%22%20slang%3D%22en-US%22%3EConfiguring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-227194%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20iOS%2012%20beta%206%20installed%2C%20and%20Im%20using%20Apple%20Configurator%202.8%20to%20generate%20a%20ActiveSync%20payload%20that%20contains%20the%20new%20OAuth%202.0%20settings.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20deployment%20and%20setup%20of%20the%20Exchange%2FActiveSync%20profile%20is%20smooth%20and%20easy%20in%20iOS%2012%20as%20expected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20final%20end-user%20step%20is%20the%20GUI%20prompt%20to%20enter%20a%20MFA%20code%20(via%20SMS%20or%20the%20MS%20Authenticator%20app).%20Pretty%20much%20performs%20as%20expected%20too%20(other%20than%20a%20couple%20extra%20taps%20and%20'hops'%20to%20the%20MS%20cloud).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20I%20am%20experiencing%20is%20that%20Mail%2FContacts%2FCalendar%20stop%20syncing%20after%20a%20couple%20hours%20of%20deployment.%20At%20this%20time%2C%20I%20see%20a%20generic%20%22Failed%20to%20connect%20to%20server%22%20error.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20is%20no%20way%20to%20force%20a%20new%20session%2Ftoken.%20No%20way%20to%20re-authenticate%20again%20(i.e.%3B%20no%20password%20field).%20All%20ActiveSync-based%20services%20stop%20working%20until%20the%20MDM%20profile%20is%20removed%20and%20re-deployed%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERinse%20%26amp%3B%20repeat.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20deploying%20the%20Apple%20.mobileconfig%20(XML)%20profile%20to%20my%20test%20iOS%2012%20devices%20via%20USB%20(Apple%20Configurator)%20and%20via%20Meraki%20MDM.%20Both%20yield%20the%20same%20results.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20is%20not%20related%20to%20deployment.%20The%20problem%20clearly%20appears%20to%20be%20a%20session%20time-out%20or%20a%20token%20refresh%20failure.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMFA%20(multi-factor%20authentication)%20works%20great%20on%20our%20Macs%20and%20Windows%20PCs%20(including%20Outlook%202016%2C%20Skype%20for%20Business%2C%20Outlook%20Webmail%2C%20etc).%20Both%20SMS%20and%20the%20Microsoft%20Authenticator%20app%20work%20fine%20for%20one-time%20passcodes%20too.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20App%20Passwords%20are%20used%20in%20my%20environment%20(other%20than%20the%20initial%20App%20Password%20generated%20automatically%20by%20MS%20when%20an%20O365%20account%20transitions%26nbsp%3Bfrom%20'Enabled'%20to%20'Enforced'.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20been%20able%20to%20reproduce%20this%20issue%20on%20multiple%20iOS%20devices%20running%20iOS%2012%20betas%20%235%20and%20%236.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20rebuilt%20the%20MDM%20.mobileconfig%20profile%20numerous%20times%20(including%20creating%20it%20by%20hand%20in%20a%20text%20editor).%20Profile%20and%20payloads%20look%20perfect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20digging%20into%20O365%20server%2Ftenant%20logs%20now%2C%20but%20I%20don't%20see%20anything%20interesting%20yet.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20experienced%20this%20issue%3F%20Any%20help%20or%20feedback%20is%20greatly%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-227194%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAuthentication%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIdentity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-376518%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-376518%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F48605%22%20target%3D%22_blank%22%3E%40Steven%20Jenkinson%3C%2FA%3E%26nbsp%3BI%20don't%20see%20this%20as%20working%20either.%20I%20see%20that%20they%20have%20added%20OAuth%20support%20for%20Intune%20that%20Office%20365%20MDM%20is%20built%20on%2C%20but%20it%20doesn't%20seem%20to%20be%20enabled%20for%20Office%20365%20MDM%3F%20Is%20anyone%20from%20Microsoft%20monitoring%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-356120%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-356120%22%20slang%3D%22en-US%22%3E%3CP%3EJust%20wondered%20if%20you%20ever%20managed%20to%20get%20O365%20MDM%20email%20profiles%20working%20for%20an%20MFA-enabled%20account%20using%20the%20Intune%20Company%20Portal%20app%20on%20iOS%2012%20(without%20using%20App%20passwords)%3F%20It%20seems%20to%20still%20not%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20my%20user%20is%20on%20an%20MFA%20Trusted%20Network%20(so%20that%20MFA%20isn't%20required)%2C%20authentication%20works%20just%20fine.%20As%20soon%20as%20the%20user%20is%20outside%20the%20Trusted%20Network%20where%20MFA%20is%20required%2C%20continuous%20password%20prompts%20are%20received%20and%20the%20iOS%2012%20Mail.app%20cannot%20authenticate.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-279413%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-279413%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20use%20O365%20MDM%20with%20MFA%20and%20it%20works%20but%20it%20requires%20the%20user%20to%20create%20an%20App%20Password%20for%20the%20native%20iOS%20Mail%20app.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-261630%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-261630%22%20slang%3D%22en-US%22%3E%3CP%3EOffice%20365%20MDM%20through%20the%20Intune%20Company%20Portal%20app%20also%20seems%20to%20not%20be%20working%20for%20deploying%20MFA%20accounts.%20I%20was%20under%20the%20impression%20that%20this%20capability%20would%20be%20added%20with%20iOS%2012%2C%20but%20the%20behavior%20seems%20to%20be%20the%20same%20as%20iOS%2011%20(no%20way%20to%20authenticate%20with%20MFA%20in%20the%20Intune%20Company%20Portal%20deployment%20process).%20Has%20anyone%20gotten%20this%20to%20work%20since%20iOS%2012%20was%20released%3F%20We%20use%20both%20MFA%20and%20Office%20365%20MDM%2C%20and%20so%20far%20the%20two%20do%20not%20seem%20to%20get%20along.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-580539%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-580539%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30474%22%20target%3D%22_blank%22%3E%40Dan%20Stranathan%3C%2FA%3EHave%20you%20fond%20anything%20about%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20similar%20issue%20and%20I%20am%20deploying%20on%20IOS12.2%2B%20with%20Native%20Mail%20App%20and%20MFA.%20Deployment%20and%20first%20registration%20are%20working%20well%20but%20after%20a%20couple%20of%20hours%20mail%20stop%20syncing%20and%20I%20have%20an%20%22Account%20error%22%20message%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F114139i12745E8B8F2EAA6D%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22Error.jpg%22%20title%3D%22Error.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-656243%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-656243%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F343703%22%20target%3D%22_blank%22%3E%40StephanBrisson%3C%2FA%3E%26nbsp%3B%20so%20far%20I%20have%20had%20mixed%20results%20on%20IOS12%20devices.%26nbsp%3B%20On%20one%20of%20the%20first%20devices%20the%20native%20mail%20asked%20for%20a%20password.%26nbsp%3B%20I%20created%20an%20App%20password.%26nbsp%3B%20Would%20not%20accept%20it.%26nbsp%3B%20So%20I%20found%20an%20article%20online%20which%20suggested%20just%20deleting%20that%20account%20and%20adding%20it%20back%2C%20leaving%20whatever%20contacts%20and%20notes%20were%20already%20on%20the%20device.%20That%20took%20care%20of%20it.%26nbsp%3B%20On%20my%20iPhone%20I%20just%20entered%20the%20app%20password.%26nbsp%3B%20But%20then%20on%20my%20iPad%20that%20would%20not%20work%2C%20so%20I%20just%20removed%20the%20account%20and%20added%20it%20back.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-656501%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-656501%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F88309%22%20target%3D%22_blank%22%3E%40Jim%20Hill%3C%2FA%3E%26nbsp%3BIt's%20supposed%20to%20work%20with%20Modern%20Authentication%2FOAuth%2C%20without%20the%20need%20to%20use%20an%20app%20password.%20Needing%20an%20app%20password%20for%20email%20on%20a%20phone%20for%20all%20users%20that%20are%20on%20MFA%20is%20absurd%20in%202019.%20It's%20supposed%20to%20be%20best%20practice%20to%20turn%20on%20MFA%20for%20all%20users%20these%20days%2C%20but%20Office%20365%20MDM%20doesn't%20support%20it%3F%20I'm%20astounded%20this%20hasn't%20gotten%20more%20attention.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-669344%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-669344%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F343703%22%20target%3D%22_blank%22%3E%40StephanBrisson%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20also%20having%20the%20exact%20same%20issue%2C%20since%20around%20iOS%2012.2%3C%2FP%3E%3CP%3EWe've%20extracted%20logs%20from%20a%20device%20and%20they%20talk%20about%20oAuth%20tokens%20failing%20to%20refresh.%3C%2FP%3E%3CP%3ERaised%20support%20ticket%20with%20Microsoft%20but%20they%20havent%20been%20able%20to%20assist.%3C%2FP%3E%3CP%3EHave%20you%20had%20any%20progress%20or%20luck%20with%20your%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EError%26gt%3B%3A%20%3CSTRONG%3EDAEASOAuthTokenRefreshResponse%3C%2FSTRONG%3E%20response%20is%20not%20NSHTTPURLResponse.%20Game%20over%3C%2FP%3E%3CP%3E%3CNOTICE%3E%3A%20Received%20a%20Transient%20Network%20Error%3A%20%3CSTRONG%3Erefrehing%20OAuth%20Token%20failed%20with%20Error%20Error%20Domain%3DNSURLErrorDomain%20Code%3D-1002%3C%2FSTRONG%3E%20%22unsupported%20URL%22%20UserInfo%3D%7BNSLocalizedDescription%3Dunsupported%20URL%2C%20NSUnderlyingError%3D0x102bc0ce0%20%7BError%20Domain%3DkCFErrorDomainCFNetwork%20Code%3D-1002%7D%7D%3C%2FNOTICE%3E%3C%2FP%3E%3CP%3EMay%2013%2011%3A45%3A26%20iPhone%20accountsd(DAAccountAuthenticator)%5B1296%5D%20%3CERROR%3E%3A%20Authenticator%20FAILED%20Trying%20To%20Refresh%20OAuth2%20credentials%20for%20account%20%3CPRIVATE%3E%20Networking%20Error%3C%2FPRIVATE%3E%3C%2FERROR%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-669667%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-669667%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F354132%22%20target%3D%22_blank%22%3E%40webber1979%3C%2FA%3EYes%20we%20were%20able%20to%20make%20it%20work%20properly.%20We%20are%20using%20Airwatch%20(VMware%20Workspace%20One)%20and%20we%20had%20to%20change%20our%20email%20profiles%20deployment%20parameters.%20We%20had%20to%20add%20the%20OAuth%20parameter%20to%20the%20email%20profile%20but%20then%20the%20user%20name%20in%20the%20profile%20was%20the%20following%3A%20domain%5Cuser%40domain.%20It%20was%20working%20in%20the%20initial%20logon%20(for%20about%20an%20hour)%20but%20when%20the%20refresh%20token%20was%20expiring%20the%20profile%20was%20unable%20to%20match%20the%20user%20name%20with%20anything.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20had%20to%20delete%20the%20username%20and%20the%20domain%20from%20the%20Email%20profile%20(pushed%20by%20Airwatch)%20and%20then%20it%20worked%20fine.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-670414%22%20slang%3D%22en-US%22%3ERe%3A%20Configuring%20iOS%2012%20for%20O365%20Exchange%20using%20MFA%20(OAuth)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-670414%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3BThanks%20for%20the%20reply.%3C%2FP%3E%3CP%3EThink%20your%20issue%20might%20be%20different%20to%20ours%2C%20we%20already%20have%20oAuth%20turned%20on%20and%20we%20use%20UPN%20as%20the%20username.%20I've%20changed%20this%20to%20primarysmtpaddress%20and%20hope%20this%20may%20help.%3C%2FP%3E%3CP%3EI've%20also%20tried%20removing%20their%20activesync%20device%20partnership%20prior%20to%20the%20migration%20to%20see%20if%20this%20helps.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Dan Stranathan
New Contributor

I have iOS 12 beta 6 installed, and Im using Apple Configurator 2.8 to generate a ActiveSync payload that contains the new OAuth 2.0 settings.

 

The deployment and setup of the Exchange/ActiveSync profile is smooth and easy in iOS 12 as expected.

 

The final end-user step is the GUI prompt to enter a MFA code (via SMS or the MS Authenticator app). Pretty much performs as expected too (other than a couple extra taps and 'hops' to the MS cloud).

 

The problem I am experiencing is that Mail/Contacts/Calendar stop syncing after a couple hours of deployment. At this time, I see a generic "Failed to connect to server" error.

 

There is no way to force a new session/token. No way to re-authenticate again (i.e.; no password field). All ActiveSync-based services stop working until the MDM profile is removed and re-deployed again.

 

Rinse & repeat.

 

I'm deploying the Apple .mobileconfig (XML) profile to my test iOS 12 devices via USB (Apple Configurator) and via Meraki MDM. Both yield the same results.

 

The problem is not related to deployment. The problem clearly appears to be a session time-out or a token refresh failure.

 

MFA (multi-factor authentication) works great on our Macs and Windows PCs (including Outlook 2016, Skype for Business, Outlook Webmail, etc). Both SMS and the Microsoft Authenticator app work fine for one-time passcodes too.

 

No App Passwords are used in my environment (other than the initial App Password generated automatically by MS when an O365 account transitions from 'Enabled' to 'Enforced'.

 

I have been able to reproduce this issue on multiple iOS devices running iOS 12 betas #5 and #6.

 

I have rebuilt the MDM .mobileconfig profile numerous times (including creating it by hand in a text editor). Profile and payloads look perfect.

 

I am digging into O365 server/tenant logs now, but I don't see anything interesting yet.

 

Has anyone else experienced this issue? Any help or feedback is greatly appreciated.

10 Replies

Office 365 MDM through the Intune Company Portal app also seems to not be working for deploying MFA accounts. I was under the impression that this capability would be added with iOS 12, but the behavior seems to be the same as iOS 11 (no way to authenticate with MFA in the Intune Company Portal deployment process). Has anyone gotten this to work since iOS 12 was released? We use both MFA and Office 365 MDM, and so far the two do not seem to get along.

We use O365 MDM with MFA and it works but it requires the user to create an App Password for the native iOS Mail app.

Just wondered if you ever managed to get O365 MDM email profiles working for an MFA-enabled account using the Intune Company Portal app on iOS 12 (without using App passwords)? It seems to still not work.

 

When my user is on an MFA Trusted Network (so that MFA isn't required), authentication works just fine. As soon as the user is outside the Trusted Network where MFA is required, continuous password prompts are received and the iOS 12 Mail.app cannot authenticate.

@Steven Jenkinson I don't see this as working either. I see that they have added OAuth support for Intune that Office 365 MDM is built on, but it doesn't seem to be enabled for Office 365 MDM? Is anyone from Microsoft monitoring this?

@Dan StranathanHave you fond anything about this?

 

I have a similar issue and I am deploying on IOS12.2+ with Native Mail App and MFA. Deployment and first registration are working well but after a couple of hours mail stop syncing and I have an "Account error" message:

 

 

Error.jpg

 

 

@StephanBrisson  so far I have had mixed results on IOS12 devices.  On one of the first devices the native mail asked for a password.  I created an App password.  Would not accept it.  So I found an article online which suggested just deleting that account and adding it back, leaving whatever contacts and notes were already on the device. That took care of it.  On my iPhone I just entered the app password.  But then on my iPad that would not work, so I just removed the account and added it back.  

@Jim Hill It's supposed to work with Modern Authentication/OAuth, without the need to use an app password. Needing an app password for email on a phone for all users that are on MFA is absurd in 2019. It's supposed to be best practice to turn on MFA for all users these days, but Office 365 MDM doesn't support it? I'm astounded this hasn't gotten more attention.

@StephanBrisson 

 

We are also having the exact same issue, since around iOS 12.2

We've extracted logs from a device and they talk about oAuth tokens failing to refresh.

Raised support ticket with Microsoft but they havent been able to assist.

Have you had any progress or luck with your issue?

 

Error>: DAEASOAuthTokenRefreshResponse response is not NSHTTPURLResponse. Game over

<Notice>: Received a Transient Network Error: refrehing OAuth Token failed with Error Error Domain=NSURLErrorDomain Code=-1002 "unsupported URL" UserInfo={NSLocalizedDescription=unsupported URL, NSUnderlyingError=0x102bc0ce0 {Error Domain=kCFErrorDomainCFNetwork Code=-1002}}

May 13 11:45:26 iPhone accountsd(DAAccountAuthenticator)[1296] <Error>: Authenticator FAILED Trying To Refresh OAuth2 credentials for account <private> Networking Error

@webber1979Yes we were able to make it work properly. We are using Airwatch (VMware Workspace One) and we had to change our email profiles deployment parameters. We had to add the OAuth parameter to the email profile but then the user name in the profile was the following: domain\user@domain. It was working in the initial logon (for about an hour) but when the refresh token was expiring the profile was unable to match the user name with anything.

 

We had to delete the username and the domain from the Email profile (pushed by Airwatch) and then it worked fine.

 Thanks for the reply.

Think your issue might be different to ours, we already have oAuth turned on and we use UPN as the username. I've changed this to primarysmtpaddress and hope this may help.

I've also tried removing their activesync device partnership prior to the migration to see if this helps.