SOLVED

System cannot find the path specified, failing to create VHD

Occasional Contributor

I have been going in circles trying to figure out why FSlogix is failing to find the path to create the VHD.  If a user has access to the VHD storage location after they log in why is FSLogix failing to create a VHD for them?

 

To sum up the issue:

  • New install, Win10 Azure Virtual Desktop with Azure Files share for storing VHD.
  • FSLogix settings controlled by Group Policy, confirmed they are being set in local registry
  • Have tried several accounts, same results
  • FSLoigx reports that the path cannot be accessed
  • But the user can open the path and create files/folders.
  • Running latest FSLogix release

 

Screenshot of errors:

jimatbutler_0-1653405812831.png

From the FSLogix troubleshooting page with what I have done to figure this out.

  • Compare the current values of Status, Reason, and Error to the documentation here.
    • What the logs are reporting - status 6, reason 5, error 3
    • 6 = There was an error determining the path to the VHD/X file.
    • 5 = five is not listed in the documentation
    • 3 = The system cannot find the path specified.
  • Verify all prerequisites have been met
    • As far as I can tell I have met all prereqs
  • Is the 'Enabled' setting set to '1'?
    • Yes
  • Do you have a valid file system location in the 'VHDLocations' setting?
    • I can copy the path from the logs, the one that I have set via group policy, and put that in explorer and it opens up the folder without error.  
  • Does the user have appropriate permissions to the VHD(X) file on the file server?
    • I can also create files and folders in the location defined to store the VHD
  • Is the user a member of the local FSLogix Profiles Include group and NOT a member of the FSLogix Profiles Exclude group?
    • Is a member of include and not a member of exclude
  • Does a local profile already exist for the user?
    • No local profile
1 Reply
best response confirmed by jimatbutler (Occasional Contributor)
Solution
Figure out what was causing my issue. In the gpo settings I enabled "Virtual disk type" and set it to VHDX. Once I flipped it back to no configured the profile created successfully.

I also have the gpo "Dynamic VHD(X) allocation" enabled so it did create a VHDX file.

Not sure why this fixed it but it's working now.