Only up to 5 users can login, following won't attach profile disk

Copper Contributor

We have a RDS cluster with 2 hosts, since a few days one host has a problem that it can handle 5 users only. Every next user has problems logging in, it won't attach the profile disk.

Details about environment:
- Windows server 2022

- FSLogix 2.9.8228.50276 -> Issue the same after updating to 2.9.8612.60056
- Profile disks on separate file server SMB share

- Appx and recycle bin roaming is disabled

The first 5 users can login normally, but the 6th user starts to have problems. It is stuck for 5 minutes on "Please wait for the FSLogix Apps Services". When I check the logs I can see a timeout (5 minutes) when trying to attach the profiledisk:


[10:13:50.811][tid:00000c0c.00005d94][INFO] Configuration setting not found: SOFTWARE\FSLogix\Profiles\LockedRetryInterval. Using default: 5
[10:18:50.868][tid:00000c0c.00005d94][ERROR:00000079] Failed to attach VHD. (The semaphore timeout period has expired.)
[10:18:50.868][tid:00000c0c.00005d94][INFO] VHD(x) attach request returning after 300016 milliseconds
[10:18:50.873][tid:00000c0c.00005d94][INFO] Status set to 12: Cannot attach to virtual disk
[10:18:50.874][tid:00000c0c.00005d94][INFO] ErrorCode set to 121 - Message: The semaphore timeout period has expired.
[10:18:50.874][tid:00000c0c.00005d94][ERROR:00000079] Failed to attach virtual disk: \\fs01\Profiles$\user_xxxx_S-1-5-21-1315411913-3787531913-3827759124-6435\Profile_user_xxxx.VHDX (The semaphore timeout period has expired.)
[10:18:50.875][tid:00000c0c.00005d94][INFO] Session configuration wrote (DWORD): SOFTWARE\FSLogix\Profiles\Sessions\S-1-5-21-1315411913-3787531913-3827759124-6435\RefCount = '0'


In the Windows eventviewer (Application) I can see the following warnings:

The winlogon notification subscriber <frxsvc> is taking long time to handle the notification event (Logon).

The winlogon notification subscriber <frxsvc> took 300 second(s) to handle the notification event (StartShell).


And sometimes the following:
The Desktop Window Manager process has exited. (Process exit code: 0x800401f0, Restart count: 1, Primary display device ID: )


What I've tried so far:
- Update FSLogix
- Disabled AV software (Sophos)

The RDS collection contains two servers, the other server does not have this problem. We couldn't find any obvious difference between de servers.

10 Replies


We are having the same problem in one of our RD farms. One RD server out of eight gets intermittant [ERROR:0000001f] in the FSLogix log and in Event viewer:Microsoft-FSLogix-Apps-Operational we get id 26 "AttachVirtualDisk error (The semaphore timeout period has expired.)" or some variant of semaphore timeout error.


All servers have identical settings, versions and OS patches. All are connecting to the same fileshare for VHDX. No clue whats going on here.

We are behind on the FSlogix version so we might try to upgrade that first though. We run multiple farms with this setup and all have same version of FSlogix but only this one server gets these errors.


Please open a MS support case as we are tracking some known issues around this semaphore time out and need to collect information as we can't reproduce the issue. This issue is related to SCSI registrations not getting properly cleaned in Windows - not necessarily an FSLogix issue, but we are looking at a way to handle it until there is a fix in Windows (potentially)
Did you manage to find a solution for this issue? We are experiencing the exact same issue with two different clients.
We also have the same issue on one of our 2022 servers. FSLogix version is now 2.9.8784.63912. But we also had it on another server with a other version. Did anyone have success fixing this issue without reinstalling the server?
Did you get any result out of the MS support case? We still face the same issue and also opened a case. Can you share your case number to reference in my support case?
Thank you!
It was corrupt entries within the below registry left behind by Fslogix incorrectly unmounting the UPD. The incorrect registry keys will not contain a ClassGUID, delete them out. In my case I had 4 corrupt entries. Let me know how you get on.



Im unable to take over permissions and ownership of all the subkeys. 

Can you help me with that?

You'll need to run PsExec /s /i regedit.exe. PsExec can be downloaded from:

I also found disabling this key resolved this on impacted machines once the key was removed:

This solved our issue! Thank you for posting this fix.