Latest FSLogix and New Teams - how to get that working reliably

Brass Contributor

Hi Everyone


I've spending a long time earlier this year getting Teams and Office working reliably with FSLogix, I'm now trying to get the new Teams (23306.3308.2524.1744 as of posting this message) working reliably between Windows 10 desktops using FSLogix (for hotdesking requirements).


I used the following article to deploy the new Teams to a set of test desktops running Windows 10 22H2 x64 and FSLogix 2.9.8612.60056


I logged in as a test user, started the New Teams from the Start Menu (got a GPO stopping it auto-starting) and it sets itself up correctly.

It them reports that there is a newer version and I upgrade it to 23306.3308.2524.1744

After that, the upgrade message no longer appears


I then log off, and log onto another test desktop.

Again starting New Teams from the start menu and it appears to go through the same initialisation / configuration routing, but reports the new version (23306.3308.2524.1744), and also says that there is an upgrade available. 

If I perform the upgrade, it downgrades the version to the version that was originally installed on that desktop, not the new version that was upgraded to the the other desktop.


Is this a bug in Teams or an issue with FSLogix/misconfiguration in redirections.xml?


Has anyone successfully deployed the New Teams with FSLogix?


One excellent point with the new Teams is that the horrendous bloating of the profiles are a thing of the past now. 




Ken Z

20 Replies

@Ken Zygmunt 

We're experiencing the same issue.
All the user settings and configurations are now stored in: C:\Users\alland\AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams
But FSLogix excludes most folders in Packages\MSTeams_8wekyb3d8bbwe\.

Hi @Ken Zygmunt  I have been waiting for the new VDI version of the teams client which has now launched, but at the bottom of the page MS are saying there is problem with FSLogix and it is not yet supported. I run a Citrix environment using FSLogix, its annoying as we could do with the new client as we are also working on a Cross tenant sync project which the new Teams client works nicely with.  There exact wording on the site is;



Currently, the new Teams client in VDI is not compatible with FSLogix Profile containers and ODFC containers. Microsoft is working on a solution and plan to remove these limitations soon."


You can see it here if you scroll down near the bottom. 

New Microsoft Teams for Virtualized Desktop Infrastructure (VDI) - Microsoft Teams | Microsoft Learn


I suspect its the same with the normal client too, but not 100% sure. 




Hi Keith

there is a new version of FSLogix (hotfix 3 - 2.9.8716) but it's in preview. I'm testing that at the moment and it seems to be working with the new Teams.


Ken Z

@Ken Zygmunt Would you be able to share the GPO setup you have on disabling Teams 2.0 from auto starting? 



best response confirmed by Karl_Wester-Ebbinghaus (MVP)
FSLogix 2210 hotfix 3 is GA!

Yes i can. Give me 24 hours to get this for you.

I'd like to see this also. But my issue is the new Teams is auto starting in VDI with latest FSLogix build after the first startup. Can you also share your exclusions for teams in fslogix?

Hi Ken, wanted to see if you have had a chance to gather the GPO settings you have set to disable Teams 2.0 from autostarting?
Hi Luis
I've tried attaching screenshots of my GPO but I don't think it's possible. If you can send me your DM I'll email you the screenshots.
At the moment I've got Teams Auto-starting because that's the way I want it but will investigate how to disable it.
Ken Z

@Jason_Parker I installed it, and new Teams is there and logs in fine from session host to session host. It doesn't seem to save all the settings though. For example, my color scheme keeps reverting after I change it. Anything else I need to do other than just install that version?

@Jason_Parker Hi, I have the latest FSLogix installed in the master-image but when I login to a Citrix-session, the new-Teams won't start. Only when I remove my profile from FSLogix and login with a clean profile (no profile) it rebuilds the profile from scratch and then the new Teams is able to start up.


I really have no clues anymore on how/what to configure. I even have used the GPO FSLogix [ see attached screenshot ] but that doesn't seem to work either:


Same thing happend to me. Deleted my profile and after that it worked fine. Need to find a solution for existing profiles.
Are there some News on this?

Hi All. I'm also being hit by this exact issue. Spent the better part of 8 hours trying everything under the sun to get it working, so it's just reassuring to know I'm not the only one


We have a case raised with Microsoft to look at this, so I'll let you know when they have an update



Do you have any news? I have the same problem. If I create a new Fslogix profile, new Teams works, but with the existing one it doesn't start.


best regards

@sanso1979 Hey. Not yet, I had a case open with MS but they somehow found a way to close it without actually resolving the issue, so I've raised a new case.


We've had to set all users to use Old Teams in the Teams management portal, as a temporary fix, but this'll only work until the end of June when Old Teams gets depreciated


I'll let this chain know any updates

I have a working work-around:
When users log in, the following mandatory script is run. This installs the new-Teams with the user's credentials, it looks like something is written in the userprofile as well:
cd \Program Files\Microsoft Teams Installer\
teamsbootstrapper.exe -p -o "C:\Program Files\Microsoft Teams Installer\MSTeams-x64.msix"
If the return-code is 'true' (that means the installation is succesfull) users can then start new-Teams via START -> Microsoft Teams (Work or School).

@Ken Zygmunt not sure if everyone has seen this update but seems like Microsoft and Citrix are working on updates to make things better. We shall see how things look in June.

Luis (and anyone else)

to stop new Teams from auto-starting, see this article

In that regkey is a reg-value called "State". Set it to a value of 1

tested and working with the latest new teams on Windows 10


Ken Z
1 best response

Accepted Solutions
best response confirmed by Karl_Wester-Ebbinghaus (MVP)