FSLogix issues with legacy VB6 app on 2019 RDS

New Contributor

Hi guys,

 

I asked this question the other day over on the MS Learn Q&A Forum however it may actually be better suited here. 

 

I'm hoping to get some advice or assistance with a really frustrating issue that I have been experiencing with FSLogix for the last week.

I'm using FSLogix (2201 Hotfix 2) in a Windows Server 2019 RDS environment which has running in it an older VB6 desktop application (Yeah I know...)

The issue that I am seeing is that when a user is connected to one of the RDS boxes with a FSLogix profile, the application soft crashes as it seems as though it doesn't have permission to copy the common files for the app to the user's VirtualStore. At least that's what I believe. When a user logs in with a local account or a domain account that's excluded from FSLogix, the application works as expected.

Some of the errors that are thrown are "Run-time error '5': Invalid procedure call or argument" or "Error Loading Control : {ControlName} : Path/File access error"

I have tried a few things already like disabling UAC Virtualization https://learn.microsoft.com/en-us/answers/questions/744893/fslogix-profile-container-and-uac-file-vi.... I've also tried implementing the redirections.xml to exclude VirtualStore with no luck.

Digging through procmon hasn't really given me much insight into the issue however I have seen a number of file operations with result BUFFER OVERFLOW... when running the app from a user with a FSLogix profile. These aren't there with the local user or domain user with local profile.

Event Viewer logs have told me nothing and there's very little in regard to logging with the application.

I'm absolutely stumped with this issue and have been stressing over this for the last few days.

Any help would be appreciated.

1 Reply
Further to this, I've also run across this which looks to be a very similar issue. https://social.msdn.microsoft.com/Forums/en-US/86c78bcc-40fb-4db2-883d-5fbd375bfa52/fslogix-applicat.... Setting "SetTempToLocalPath" doesn't seem to be doing much as %TEMP% and %TMP% still seem to point to the local path. I am still having issues with the application though but I can see it creating .TMP files where I'd expect it to.