Test-HybridConnectivity failing

Occasional Visitor

I have an Exchange 2013 server running on Server 2012 R2 that I am trying to migrate to Exchange Online with a hybrid configuration. I have setup the AD Connect without an issue. However, before I installed the HCW, I tried to run the Test-HybridConnectivity powershell in the HybridManagement module. It fails with the following errors. I believe it is an issue with TLS 1.2 so I have tried using the command "[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12" from this article but have the same error. I tested on a standard 2012 R2 server and it also fails at first but that command makes it succeed. I also tried setting the registry keys in SCHANNEL\Protocols\TLS 1.2\Server and Client and restarting. There are several clients that I will be migrating this way and all of them fail the test script. 

 

 

[PS] C:\Windows\system32>Import-Module C:\Scripts\HybridManagement.psm1
[PS] C:\Windows\system32>Test-HybridConnectivity -testO365Endpoints
Testing connection to mscrl.microsoft.com on port 80
Testing connection to crl.microsoft.com on port 80
Testing connection to ocsp.msocsp.com on port 80
Testing connection to www.microsoft.com on port 80
Testing connection to login.windows.net on port 443
WARNING: Ping to login.windows.net failed -- Status: TimedOut
Testing connection to login.microsoftonline.com on port 443
WARNING: Ping to login.microsoftonline.com failed -- Status: TimedOut
Testing connection to outlook.office.com on port 443
Performing GET on https://outlook.office.com:443
Testing connection to outlook.office365.com on port 443
Performing GET on https://outlook.office365.com:443
Testing connection to nexus.microsoftonline-p.com on port 443
WARNING: Ping to nexus.microsoftonline-p.com failed -- Status: TimedOut
Performing GET on https://nexus.microsoftonline-p.com:443
Invoke-WebRequest : The underlying connection was closed: An unexpected error occurred on a send.
At C:\Scripts\HybridManagement.psm1:196 char:19
+ $result = Invoke-WebRequest -Method Get -Uri $uri
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebExc
eption
+ FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand

4 Replies

Hi @MarkMageau 
Im getting the exact same error. 

Also Exchange 2013 Server 2012 R2.


Any luck in resolving it? 

@Danie Claassen 

 

@MarkMageau 

 

Hello did either of you manage to get this working?  Same issue here. Exchange 2013 on 2012 R2

I'm seeing the same thing today on an Exchange 2019 Server on Windows Server 2019.
@MarkMageau
@Danie Classen
@MAC1978590

Anyone ever figure out the cause?

Hi @Jarrod_Johnston 
Try and install the Migration Wizzard in a server with a newer O/S.
Maybe Windows Server 2019.