SOLVED

SPF lookup Failed and i dont know why

%3CLINGO-SUB%20id%3D%22lingo-sub-1193504%22%20slang%3D%22en-US%22%3ESPF%20lookup%20Failed%20and%20i%20dont%20know%20why%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1193504%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Guys.%20So%20my%20SPF%20Records%20looks%20like%20the%20following%3A%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%230000FF%22%3Ev%3Dspf1%20mx%20ip4%3A91.198.79.139%20ip4%3A217.26.51.230%20include%3Aspf.surveymonkey.com%20include%3A_spf.salesforce.com%20include%3Aspf.protection.outlook.com%20include%3Aet._spf.pardot.com%20include%3Aaspmx.pardot.com%20%3CSTRONG%3Einclude%3Aspf.mail.hostpoint.ch%3C%2FSTRONG%3E%20include%3Aspf.abacuscity.ch%20~all%3C%2FFONT%3E%3C%2FP%3E%3CP%3EI%20know%20its%20a%20lot.%26nbsp%3B%20So%20when%20one%20of%20the%20server%20on%20hostpoint.ch%20(217.26.49.146)%20tries%20to%20send%20an%20email%20to%20Office%20365%20i%20get%20the%20following%20result%3A%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%230000FF%22%3EAuthentication-Results%3A%20spf%3Dnone%20(sender%20IP%20is%20217.26.49.146)%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%230000FF%22%3Esmtp.mailfrom%3Dp12.server.hostpoint.ch%3B%20noser.com%3B%20dkim%3Dnone%20(message%20not%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%230000FF%22%3Esigned)%20header.d%3Dnone%3Bnoser.com%3B%20dmarc%3Dfail%20action%3Dquarantine%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%230000FF%22%3Eheader.from%3Dnoser.com%3Bcompauth%3Dfail%20reason%3D000%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%230000FF%22%3EReceived-SPF%3A%20None%20(protection.outlook.com%3A%20p12.server.hostpoint.ch%20does%20not%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%230000FF%22%3Edesignate%20permitted%20sender%20hosts)%3C%2FFONT%3E%3C%2FP%3E%3CP%3ECan%20anyone%20explain%20to%20me%20why%20this%20is%20happening%3F%20The%20sender%20IP%20should%20be%20included%20in%20the%20record%20of%20hostpoint.ch....%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1193504%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Espf%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1321202%22%20slang%3D%22en-US%22%3ERe%3A%20SPF%20lookup%20Failed%20and%20i%20dont%20know%20why%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1321202%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F567758%22%20target%3D%22_blank%22%3E%40Lephas%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYou%20have%20too%20many%20dns%20lookups%20in%20your%20spf%20record.%26nbsp%3B%20SPF%20has%20a%20max%20of%2010%20dns%20lookups%20so%20it%20appears%20that%20you%20reached%20the%20max%20before%20it%20reached%26nbsp%3B%3CSTRONG%3Einclude%3Aspf.mail.hostpoint.ch%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETake%20a%20deeper%20look%20at%20your%20SPF%20and%20try%20to%20clean%20it%20up.%26nbsp%3B%20IP%20addresses%20do%20not%20count%20as%20a%20look%20so%20convert%20to%20IP%20where%20you%20can.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1321288%22%20slang%3D%22en-US%22%3ERe%3A%20SPF%20lookup%20Failed%20and%20i%20dont%20know%20why%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1321288%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F622524%22%20target%3D%22_blank%22%3E%40Michael_Larrivee%3C%2FA%3E%26nbsp%3BThank%20you%20so%20much.%20I%20was%20suspecting%20this%20might%20be%20the%20cause%20but%20i%20was%20never%20sure!%20I%20will%20reduce%20the%20includes%20and%20am%20sure%20that%20will%20solve%20the%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi Guys. So my SPF Records looks like the following:

v=spf1 mx ip4:91.198.79.139 ip4:217.26.51.230 include:spf.surveymonkey.com include:_spf.salesforce.com include:spf.protection.outlook.com include:et._spf.pardot.com include:aspmx.pardot.com include:spf.mail.hostpoint.ch include:spf.abacuscity.ch ~all

I know its a lot.  So when one of the server on hostpoint.ch (217.26.49.146) tries to send an email to Office 365 i get the following result:

Authentication-Results: spf=none (sender IP is 217.26.49.146)

smtp.mailfrom=p12.server.hostpoint.ch; noser.com; dkim=none (message not

signed) header.d=none;noser.com; dmarc=fail action=quarantine

header.from=noser.com;compauth=fail reason=000

Received-SPF: None (protection.outlook.com: p12.server.hostpoint.ch does not

designate permitted sender hosts)

Can anyone explain to me why this is happening? The sender IP should be included in the record of hostpoint.ch....

2 Replies
best response confirmed by Lephas (Occasional Contributor)
Solution

@Lephas 

 

You have too many dns lookups in your spf record.  SPF has a max of 10 dns lookups so it appears that you reached the max before it reached include:spf.mail.hostpoint.ch

 

Take a deeper look at your SPF and try to clean it up.  IP addresses do not count as a look so convert to IP where you can.

@Michael_Larrivee Thank you so much. I was suspecting this might be the cause but i was never sure! I will reduce the includes and am sure that will solve the problem.