Set-Mailbox Not Working

Frequent Contributor

I was trying to change the MessageCopyForSentAsEnabled property for a mailbox per the instructions in:

Messages sent from a shared mailbox aren't saved to the Sent Items folder - Exchange | Microsoft Docs


It looks pretty simple. First I did:


Get-ExoMailbox -Identity "" -properties Name,MessageCopyForSendOnBehalfEnabled,MessageCopyForSentAsEnabled


I got the results I expected. The property was set to false.


Then I did:


set-mailbox -Identity "" -MessageCopyForSentAsEnabled $True


But I get the error message:


The operation couldn't be performed because object '' couldn't be found on '*********.NAMPR10A002.PROD.OUTLOOK.COM


Any ideas why it can find the account with the Get-ExoMailbox (And Get-Mailbox) commands but can't find it with the set-mailbox command?



4 Replies
best response confirmed by John Twohig (Frequent Contributor)

@John Twohig Hi, short of time here trying to go through a couple of questions so will not suggest anything else than this. Try using the M365 admin portal instead. Groups - Shared mailboxes - Sent items (edit) tick the check boxes.



That wasn't what I was trying to do but it looks like a better solution. I didn't know that was there. 


I will have the person who is having the issue try it in the morning.



@John Twohig 




Please execute the command with alias name only as below:

Set-mailbox -Identity "AliasName" -MessageCopyForSentAsEnabled $True 


Please try this command and check the output is showing correctly or not??/


Get-Mailbox -Identity "" | fl Name, *message*

Get-Mailbox -Identity "AliasName" | fl Name, *message*




Have you tried to send it through a pipe?

Get-ExoMailbox -Identity xxx | set-mailbox -MessageCopyFor...

Same result?