SOLVED

Searching email not working on both Outlook Desktop and O365 web based mail

Occasional Contributor

 

I have a user who tells me search isn't working in Outlook 2016. 

 

They go into the inbox and start a search for a user by typing in their surname and the error is Something went wrong and your search couldn’t be completed.” 

 

This is OK at one level. It looks like indexing and possibly a broken Windows Search. Maybe look at fixing the service or look at making sure the June 2017 security updates have been applied.

 

I could live with this and look at the client side. However, in troubleshooting the issue I wanted to see if web based Outlook would provide a workaround for the user.  They tried the same search on the web, just typing a surname into the search bar, and  the error "Your request can't be completed right now. Please try again later." appeared. 

 

My understanding was that Outlook desktop search depending on the Windows OS and Outlook on the web used a totally different web based search. 

 

Now I am a little confused. I expected the web based search to work. Are these two different problems at exactly the same time? Is web based search somehow using a DLL or function on the PC browser that might lead to this issue?

 

I would be interested as to any thoughts on this. In particular is there a good documentation link about how Microsoft search works in Office 365 web based mail.

 

Thank you.

 

Stephen

 

 

4 Replies
Hello Stephen,

To my understanding you are using Exchange Online (Office 365) right?
In that case it could be (but small change) that your user is working in OWA offline mode, could you check if this is the case?
https://support.microsoft.com/en-us/office/using-outlook-web-app-offline-3214839c-0604-4162-8a97-685...

For Outlook you could indeed be facing issues with Windows Search and the index on the local computer, this is mostly the case with Outlook search related issues.
But also when using Exchange online mode and not cached it could still be related to Exchange Online.

OWA and Outlook in online mode use server side search with the Exchange Search Service which has a index so yes this should be fine assuming there isn't a service degredation on the Exchange Online cluster your mailboxes are residing on.
You can check this of course by following these steps:
https://docs.microsoft.com/en-us/office365/enterprise/view-service-health

@BemmelenPatrick

 

Thanks. Its not OWA (I guess you mean the traditional light version) it's the Outlook web based O365 mail. 

 

I needed some place to start and figure this out so I will go and read the links. 

 

 

The full version of OWA has got support for this as well but I don't expect this to be the problem you're having right now. Happy to help you if my answers don't contain the solution of course ;)
best response confirmed by stephen_dxc122 (Occasional Contributor)
Solution

@BemmelenPatrick 

 

It made no sense to me that both Outlook desktop search and Outlook web search were broken. The two are different. One using Windows and one using the web services.

 

One thing did connect them. The mailbox. Potentially the mailbox was broken in some form. I decided to move the mailbox between servers with the new-moverequest cmdlet. After waiting a while for it to complete the user could suddenly use both searches. 

 

I don't have a full explanation for this just that it was a way for me to make sure that the problem wasn't on the database on O365 in an easy way without raising a Microsoft incident. 

 

This is really just to document this worked because I don't like going to forums where how it was fixed is not documented.