SOLVED
Home

Running reports command and getting Failed to connect to the data mart.

Deleted
Not applicable

Hello All,

 

Please let me know why am i getting below message when i try to run couple of commands Get-LicenseVsUsageSummaryReport and Get-GroupActivityReport

 

Error Number: "18452". Failed to connect to the data mart.

9 Replies
Solution

Both work fine for me, maybe you should try to get the relevant reports from the Portal instead. It you dont get any data in the portal either, open a support case.

Did you ever get this resolved? I'm having the same errors using a web browser or via Excel oData Data Feed. I can access the reports via the Portal, but not via the web reporting service. I'm getting the same error regardless which report I try to run. 

@Joshua Villagomez I was able to export the reports via Admin Portal.

 

I found this article which explains 

 

https://msdn.microsoft.com/en-us/library/office/jj984332.aspx 

 

Just got this. Error Number: "18452". Failed to connect to the data mart. Exporting the report from the admin center gives me undefined in the fields. 

 

Get-ConnectionByClientTypeReport is what I am trying to run

 

Robert,

 

Do you get the same error by running the report from a browser? For example, go here: https://reports.office365.com/ecp/reportingwebservice/reporting.svc/ConnectionbyClientTypeDaily

 

It should prompt you for your O365 credentials. What results do you get?

@DeletedThanks. I'd like to test that out, but the link seems to be broken.

<m:code>ConnectionFailedException</m:code>
<m:message xml:lang="">Failed to connect to the data mart.</m:message>
</m:error>
 
I was prompted for credentials, and using a global admin account. 
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
50 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
32 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
15 Replies
Dev channel update to 80.0.355.1 is live
josh_bodner in Discussions on
67 Replies