SOLVED

Running reports command and getting Failed to connect to the data mart.

%3CLINGO-SUB%20id%3D%22lingo-sub-33804%22%20slang%3D%22en-US%22%3ERunning%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-33804%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20let%20me%20know%20why%20am%20i%20getting%20below%20message%20when%20i%20try%20to%20run%20couple%20of%20commands%26nbsp%3BGet-LicenseVsUsageSummaryReport%20and%26nbsp%3BGet-GroupActivityReport%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EError%20Number%3A%20%2218452%22.%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-33804%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-43764%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-43764%22%20slang%3D%22en-US%22%3E%3CP%3EYes%20i%20got%20the%20same%20error%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-35801%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-35801%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22line%22%3E%3CSPAN%20class%3D%22html-tag%22%3E%3CERROR%3E%3CSPAN%20class%3D%22html-attribute%22%3E%20%3CSPAN%20class%3D%22html-attribute-name%22%3Exmlns%3Am%3C%2FSPAN%3E%3D%22%3CSPAN%20class%3D%22html-attribute-value%22%3E%3CA%20href%3D%22http%3A%2F%2Fschemas.microsoft.com%2Fado%2F2007%2F08%2Fdataservices%2Fmetadata%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fschemas.microsoft.com%2Fado%2F2007%2F08%2Fdataservices%2Fmetadata%3C%2FA%3E%3C%2FSPAN%3E%22%3C%2FSPAN%3E%26gt%3B%3C%2FERROR%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22collapsible-content%22%3E%3CDIV%20class%3D%22line%22%3E%3CSPAN%20class%3D%22html-tag%22%3E%3CCODE%3E%3C%2FCODE%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22text%22%3EConnectionFailedException%3C%2FSPAN%3E%3CSPAN%20class%3D%22html-tag%22%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CDIV%20class%3D%22line%22%3E%3CSPAN%20class%3D%22html-tag%22%3E%3CMESSAGE%3E%3CSPAN%20class%3D%22html-attribute%22%3E%20%3CSPAN%20class%3D%22html-attribute-name%22%3Exml%3Alang%3C%2FSPAN%3E%3D%22%22%3C%2FSPAN%3E%26gt%3B%3C%2FMESSAGE%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22text%22%3EFailed%20to%20connect%20to%20the%20data%20mart.%3C%2FSPAN%3E%3CSPAN%20class%3D%22html-tag%22%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22line%22%3E%3CSPAN%20class%3D%22html-tag%22%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22line%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22line%22%3E%3CSPAN%20class%3D%22html-tag%22%3EI%20was%20prompted%20for%20credentials%2C%20and%20using%20a%20global%20admin%20account.%26nbsp%3B%3C%2FSPAN%3E%3C%2FDIV%3E%3CLINGO-SUB%20id%3D%22lingo-sub-35725%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-35725%22%20slang%3D%22en-US%22%3ESorry%20about%20that.%3CBR%20%2F%3E%3CBR%20%2F%3EBelow%20is%20the%20URL%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fmsdn.microsoft.com%2Fen-us%2Flibrary%2Foffice%2Fjj984332.aspx%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmsdn.microsoft.com%2Fen-us%2Flibrary%2Foffice%2Fjj984332.aspx%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-35722%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-35722%22%20slang%3D%22en-US%22%3E%3CP%3E%40DeletedThanks.%20I'd%20like%20to%20test%20that%20out%2C%20but%20the%20link%20seems%20to%20be%20broken.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-35721%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-35721%22%20slang%3D%22en-US%22%3E%3CP%3ERobert%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20get%20the%20same%20error%20by%20running%20the%20report%20from%20a%20browser%3F%20For%20example%2C%20go%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Freports.office365.com%2Fecp%2Freportingwebservice%2Freporting.svc%2FConnectionbyClientTypeDaily%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Freports.office365.com%2Fecp%2Freportingwebservice%2Freporting.svc%2FConnectionbyClientTypeDaily%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20should%20prompt%20you%20for%20your%20O365%20credentials.%20What%20results%20do%20you%20get%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-35695%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-35695%22%20slang%3D%22en-US%22%3E%3CP%3EJust%20got%20this.%26nbsp%3BError%20Number%3A%20%2218452%22.%20Failed%20to%20connect%20to%20the%20data%20mart.%20Exporting%20the%20report%20from%20the%20admin%20center%20gives%20me%20undefined%20in%20the%20fields.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGet-ConnectionByClientTypeReport%20is%20what%20I%20am%20trying%20to%20run%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-35534%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-35534%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F33907%22%20target%3D%22_blank%22%3E%40Joshua%20Villagomez%3C%2FA%3E%26nbsp%3BI%20was%20able%20to%20export%20the%20reports%20via%20Admin%20Portal.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20found%20this%20article%20which%20explains%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fmsdn.microsoft.com%2Fen-us%2Flibrary%2Foffice%2Fjj984332.aspx%26nbsp%3B%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmsdn.microsoft.com%2Fen-us%2Flibrary%2Foffice%2Fjj984332.aspx%26nbsp%3B%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-35423%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-35423%22%20slang%3D%22en-US%22%3E%3CP%3EDid%20you%20ever%20get%20this%20resolved%3F%20I'm%20having%20the%20same%20errors%20using%20a%20web%20browser%20or%20via%20Excel%20oData%20Data%20Feed.%20I%20can%20access%20the%20reports%20via%20the%20Portal%2C%20but%20not%20via%20the%20web%20reporting%20service.%20I'm%20getting%20the%20same%20error%20regardless%20which%20report%20I%20try%20to%20run.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-33872%22%20slang%3D%22en-US%22%3ERe%3A%20Running%20reports%20command%20and%20getting%20Failed%20to%20connect%20to%20the%20data%20mart.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-33872%22%20slang%3D%22en-US%22%3E%3CP%3EBoth%20work%20fine%20for%20me%2C%20maybe%20you%20should%20try%20to%20get%20the%20relevant%20reports%20from%20the%20Portal%20instead.%20It%20you%20dont%20get%20any%20data%20in%20the%20portal%20either%2C%20open%20a%20support%20case.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable

Hello All,

 

Please let me know why am i getting below message when i try to run couple of commands Get-LicenseVsUsageSummaryReport and Get-GroupActivityReport

 

Error Number: "18452". Failed to connect to the data mart.

9 Replies
Highlighted
Best Response
Solution

Both work fine for me, maybe you should try to get the relevant reports from the Portal instead. It you dont get any data in the portal either, open a support case.

Highlighted

Did you ever get this resolved? I'm having the same errors using a web browser or via Excel oData Data Feed. I can access the reports via the Portal, but not via the web reporting service. I'm getting the same error regardless which report I try to run. 

Highlighted

@Joshua Villagomez I was able to export the reports via Admin Portal.

 

I found this article which explains 

 

https://msdn.microsoft.com/en-us/library/office/jj984332.aspx 

 

Highlighted

Just got this. Error Number: "18452". Failed to connect to the data mart. Exporting the report from the admin center gives me undefined in the fields. 

 

Get-ConnectionByClientTypeReport is what I am trying to run

 

Highlighted

Robert,

 

Do you get the same error by running the report from a browser? For example, go here: https://reports.office365.com/ecp/reportingwebservice/reporting.svc/ConnectionbyClientTypeDaily

 

It should prompt you for your O365 credentials. What results do you get?

Highlighted

@DeletedThanks. I'd like to test that out, but the link seems to be broken.

Highlighted
Highlighted
<m:code>ConnectionFailedException</m:code>
<m:message xml:lang="">Failed to connect to the data mart.</m:message>
</m:error>
 
I was prompted for credentials, and using a global admin account. 
Highlighted