Running reports command and getting Failed to connect to the data mart.

Not applicable

Hello All,


Please let me know why am i getting below message when i try to run couple of commands Get-LicenseVsUsageSummaryReport and Get-GroupActivityReport


Error Number: "18452". Failed to connect to the data mart.

9 Replies
best response

Both work fine for me, maybe you should try to get the relevant reports from the Portal instead. It you dont get any data in the portal either, open a support case.

Did you ever get this resolved? I'm having the same errors using a web browser or via Excel oData Data Feed. I can access the reports via the Portal, but not via the web reporting service. I'm getting the same error regardless which report I try to run. 

@Joshua Villagomez I was able to export the reports via Admin Portal.


I found this article which explains 


Just got this. Error Number: "18452". Failed to connect to the data mart. Exporting the report from the admin center gives me undefined in the fields. 


Get-ConnectionByClientTypeReport is what I am trying to run




Do you get the same error by running the report from a browser? For example, go here:


It should prompt you for your O365 credentials. What results do you get?

@DeletedThanks. I'd like to test that out, but the link seems to be broken.

<m:message xml:lang="">Failed to connect to the data mart.</m:message>
I was prompted for credentials, and using a global admin account.