Recovering archive mailboxes

Copper Contributor

Hello all


I have had a really unwanted adventure over the past 10 days and need your expert advice please:


1 – setup

2 X DC

2 X Exchange 2019 CU3


All 4 machines running Windows 2019 standard with all the latest updates

1 exchange server holds the main mailboxes (ex8)

1 exchange server holds the archive databases (ex8-archive)


All working perfectly well, until I decided to start upgrading them to CU4. I started with the archive server so that in case of problem the downtime will not be catastrophic. CU4 install failed in the middle of the install, dumping a whole lot of code and error. Researched for days, tried setup again, server recovery, followed tons of instructions and none helped. I contacted Microsoft paid support and for 3 days, they could not solve the problem either, so they just told me to install a new machine with a different name (ex8b-archive), which OF COURSE worked and then they said their scope is complete. I am having a debate on that with them that they could not figure out the problem, its cause or solution, but right now my users are getting desperate for their archive data. Here is the current problem:


All the archive databases were on a separate virtual disk so they were unaffected by all these issues. I have used eseutil on them and they are all in clean shutdown state and good health. The first issue was how to mount these to the new server ex8B-archive. No help from Microsoft, but I followed an article which told me to create a new database with the same names elsewhere, then copy the old databases back as restore (I ticked the box where it said this database can be overwritten by restore). So far so good, all archive DBs mounted. Until I realised that now none of the users show as having archive mailbox (see attached image), although it showed that mailboxes are archive-enabled.


I disabled archive and re-enabled it for a couple of test accounts. In the process it asked me which database I want and I pointed it to the original archive database (there is one example in the image). Worked great. Except that the client cannot see any data in their archives. If I run a mailbox statistics command, it shows the size of the archive to be 0. The archive databases are still full (have around 80-100 Gb of data in them) and the retention policy is 28 days, so the data is there.


I just do not know how to recover the data. I have tried very cautiously to use New-MailboxRestoreRequest command once, but not sure if I am using it correctly or not.


New-MailboxRestoreRequest -SourceDatabase "DB14-Archive" -SourceStoreMailbox "user1” -TargetMailbox -TargetIsArchive


When I run this it says Mailbox "user1" doesn't exist on database "DB14-Archive".


So I am at a loss now and any advice would be greatly appreciated.


Thank you all in advance.

1 Reply
best response confirmed by Calvinator28 (Copper Contributor)

Hello all


Just in case anyone else comes across this issue, I managed to resolve it. Please see below links:



1 best response

Accepted Solutions
best response confirmed by Calvinator28 (Copper Contributor)