Purge MS Exchange 2013 logs

%3CLINGO-SUB%20id%3D%22lingo-sub-1934484%22%20slang%3D%22en-US%22%3EPurge%20MS%20Exchange%202013%20logs%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1934484%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20a%20problem%20purging%20Exchange%20logs.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20usually%20use%20Veeam%2C%20but%20we%20can't%20get%20log%20purging%20to%20work%20even%20with%20the%20right%20configuration.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20then%20tested%20with%20the%20Windows%20backup%20and%20found%20the%20same%20result.%20The%20backup%20ends%20but%20with%20warnings.%20The%20logs%20are%20also%20not%20purged.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20know%20if%20there%20is%20an%20effective%20script%20to%20perform%20this%20task%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EVersion%20%3A%20MS%20Exchange%202013%20CU23%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank's%20in%20advance%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1934484%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2013%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1940024%22%20slang%3D%22en-US%22%3ERe%3A%20Purge%20MS%20Exchange%202013%20logs%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1940024%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F845359%22%20target%3D%22_blank%22%3E%40Fred06%3C%2FA%3E%26nbsp%3BHow%20many%20database%20copies%20%3F%20Are%20you%20testing%20with%20a%20single%20database%20%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EGet-MailboxDatabaseCopyStatus%20*%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

 

We have a problem purging Exchange logs.

 

We usually use Veeam, but we can't get log purging to work even with the right configuration.

 

We then tested with the Windows backup and found the same result. The backup ends but with warnings. The logs are also not purged.

 

Do you know if there is an effective script to perform this task?

 

Version : MS Exchange 2013 CU23

 

Thank's in advance

3 Replies

@Fred06 How many database copies ? Are you testing with a single database ?

 

Get-MailboxDatabaseCopyStatus *

@Pierfish 

 

Hi,

 

Sorry for the late response.

 

We currently have 5 active databases.

 

After executing the command, I notice that there are indexing errors. Is it possible that the error of deleting the logs comes from there?

 

Thank you

@Fred06 yes it can depends on that. please make all of your database copies Healthy and then try with a new backup