Problem with mail delivering via SSL error 454 4.7.4

%3CLINGO-SUB%20id%3D%22lingo-sub-2155241%22%20slang%3D%22en-US%22%3EProblem%20with%20mail%20delivering%20via%20SSL%20error%20454%204.7.4%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2155241%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20we%20have%20problem%20with%20delivering%20mail%20from%20fortimail%20appliance%20to%20exchange%202016%20infrastructure%2C%20sometimes%20emails%20stuck%20at%20fortimail%20and%20not%20delivered%20to%20exchange%20with%20this%20message%3A%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Edsn%3D4.0.0%2C%20stat%3DDeferred%3A%20454%204.7.4%20temporarily%20failed%20to%20deliver%20message%20via%20SSL%2FTLS.(Reason%3A454%204.7.4%20temporarily%20failed%20to%20deliver%20message%20via%20SSL%2FTLS.)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Ethis%20errors%20ocasionally%20occurs%20and%20emails%20are%20going%20to%20timeout%20and%20not%20delivered%20after%20few%20days%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20cannot%20find%20nothing%20about%20this%20error%20code%2C%20and%20to%20troubleshoot.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThank%20you%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2155241%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2016%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2159990%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20with%20mail%20delivering%20via%20SSL%20error%20454%204.7.4%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2159990%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F127027%22%20target%3D%22_blank%22%3E%40Jozi%20Zurbej%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20issue%20can%20be%20caused%20by%20one%20of%20the%20following%20reasons%3A%3C%2FP%3E%3CUL%3E%3CLI%3EThe%20Exchange%20server%20is%20experiencing%20Time%20synchronization%20issues.%3C%2FLI%3E%3CLI%3EThere%20is%20a%20replication%20issue%20between%20the%20domain%20controllers.%3C%2FLI%3E%3CLI%3EThe%20Exchange%20server%20is%20experiencing%20Service%20Principal%20Name%20(SPN)%20issues.%3C%2FLI%3E%3CLI%3EThe%20required%20TCP%2FUDP%20ports%20for%20the%20Kerberos%20protocol%20are%20blocked%20by%20the%20firewall.%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Ftroubleshoot%2Fclient-connectivity%2F454-4-7-0-temporary-authentication-failure%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Ftroubleshoot%2Fclient-connectivity%2F454-4-7-0-temporary-authentication-failure%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.thecloudtechnologist.com%2Fhow-to-fix-exchange-online-hybrid-outbound-connector-454-4-7-5-certificate-validation-failure%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.thecloudtechnologist.com%2Fhow-to-fix-exchange-online-hybrid-outbound-connector-454-4-7-5-certificate-validation-failure%2F%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EMD%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi we have problem with delivering mail from fortimail appliance to exchange 2016 infrastructure, sometimes emails stuck at fortimail and not delivered to exchange with this message: 

 

dsn=4.0.0, stat=Deferred: 454 4.7.4 temporarily failed to deliver message via SSL/TLS.(Reason:454 4.7.4 temporarily failed to deliver message via SSL/TLS.)

this errors ocasionally occurs and emails are going to timeout and not delivered after few days,

I cannot find nothing about this error code, and to troubleshoot.

 

Thank you

1 Reply

@Jozi Zurbej 

 

Hi,

 

The issue can be caused by one of the following reasons:

  • The Exchange server is experiencing Time synchronization issues.
  • There is a replication issue between the domain controllers.
  • The Exchange server is experiencing Service Principal Name (SPN) issues.
  • The required TCP/UDP ports for the Kerberos protocol are blocked by the firewall.

https://docs.microsoft.com/en-us/exchange/troubleshoot/client-connectivity/454-4-7-0-temporary-authe... 

https://www.thecloudtechnologist.com/how-to-fix-exchange-online-hybrid-outbound-connector-454-4-7-5-... 

Regards,

MD