Outlook intermittent issues connecting to Exchange Online

Copper Contributor

I have a client with three server Windows Server 2019 RD Session Host farm. In addition, many users are running Windows 10 Enterprise. Both of these have the same key build number. The RD Session Host and the end user PCs are running Microsoft 365 Apps for Enterprise. All mailboxes are in Exchange Online. For months we have had intermittent issues with some, but not all, users.


Intermittently when a user, often on a RD Session Host, opens Outlook he or she gets this error:


Cannot start Microsoft Outlook. Cannot open the Outlook window. The set of folders cannot be opened. The information store could not be opened.


On the RD Session Host the Outlook profiles are in online mode not cached mode.   


Things we have tried:

  • When this occurs we are unable to create a new Outlook profile as it gives an error. I don't have the specific verbiage but fundamentally it's unable to connect to the user mailbox or information store.
  • If the user opens a web browser he or she can access business email via Outlook Online.
  • If the user logs off that RD Session Host and is forced to login to a different one often Outlook will connect to Exchange Online on that second RD Session Host. If the user remains on the initial RD Session Host later that day Outlook may be able to connect.
  • We modified the Sonicwall hardware firewall's geo-IP filter to not block outbound connections based on destination country. 
  • Users have Office 365 E3 licenses, therefore, there are no Conditional Access policies.
  • Users do not have Azure AD MFA explicitly enabled on their accounts.
  • We are using Cisco Umbrella with the OpenDNS DNS servers. The RD Session Hosts do not have the Cisco Umbrella Roaming Client installed as they don't leave the network. The Windows Server DNS Server roles are configured to forward to OpenDNS. I enabled DNS debug logging and reviewed the DNS queries from a recent incident. I found no DNS queries with result other than NOERROR. The second DNS server's log wrapped prior to the most recent incident. Globally we are blocking pastebin.com and github.io. I found neither of them in the DNS log.
  • The most recent user who had the problem is a new employee with a very small user mailbox.
  • We worked with our CSP and Microsoft tech support but they were unable to figure it out.
  • During the most recent incident I explored starting Outlook logging but in order to do that you need to go into the Outlook options...which I couldn't access.


I'm running out of ideas. The intermittent nature and the fact that it's not impacting all users has me frustrated and running out of places to look. Do I need to look at installing and configuring FSLogix and have the RD Session Host users transition to Outlook with cached mode? As far as I know this is the only client where we are having this issue and I'm having trouble figuring out what's unique about them. 

0 Replies