Outlook Client unable to search on Server. 'Server unavailable. 12 months of results shown.'

Copper Contributor
I am getting this error with a client on a main workstation, but another workstation searches via Outlook works OK
One workstation is running Office 365 Pro Plus 1902 - not working
Another Laptop runs Office 2016 and works
My process to migrate from 2013 to 2019 included - making MAPI enabled. I added 3 servers that I will DAG, asnd eventually take down the 3 2013 servers (but they are still up and running).
I ran the following (with my server names) on my 3 new servers
1 Get-OutlookAnywhere -Server srvexc2019 | Set-OutlookAnywhere -InternalHostname ex02.mydomain.com -InternalClientAuthenticationMethod Ntlm -InternalClientsRequireSsl $true -ExternalHostname ex02.mydomain.com -ExternalClientAuthenticationMethod Basic -ExternalClientsRequireSsl $true -IISAuthenticationMethods Negotiate,NTLM,Basic
1 Get-EcpVirtualDirectory -Server srvexc2019 | Set-EcpVirtualDirectory -InternalUrl https://ex02/mydomain.com/ecp -ExternalUrl https://ex02.mydomain.com/ecp
1 Get-OwaVirtualDirectory -Server srvexc2019 | Set-OwaVirtualDirectory -InternalUrl https://ex01.mydomain.com/owa -ExternalUrl https://ex02.mydomain.com/owa
1 Get-WebServicesVirtualDirectory -Server srvexc2019 | Set-WebServicesVirtualDirectory -InternalUrl https://ex02.mydomain.com/EWS/Exchange.asmx -ExternalUrl https://ex02.mydomain.com/EWS/Exchange.asmx
1 Get-ActiveSyncVirtualDirectory -Server srvexc2019 | Set-ActiveSyncVirtualDirectory -InternalUrl https://ex02.mydomain.com/Microsoft-Server-ActiveSync -ExternalUrl https://ex02.mydomain.com/Microsoft-Server-ActiveSync
1 Get-OabVirtualDirectory -Server srvexc2019 | Set-OabVirtualDirectory -InternalUrl https://ex01.mydomain.com/OAB -ExternalUrl https://ex02.mydomain.com/OAB
1 Get-MapiVirtualDirectory -Server srvexc2019 | Set-MapiVirtualDirectory -InternalUrl https://ex02.mydomain.com/mapi -ExternalUrl https://ex02.mydomain.com/mapi
I can search OK from online owa
Any Idea how to fix the search on Outlook client
4 Replies

Continued playing with the outlook client.


I right clicked an email address and opened Data File Properties.


I clicked on Folder size. Closed it, and then it just worked.


I went back to the DataFileProperties, and my Sync Issues went from 144k to 9k


Now it seems to work ??? Asks for 'find more on server' where it finds the search items OK.


Any idea what is going on?


while it doesn't answer your question: I had the exact same issue on one client and followed the steps you did (with one exception, I clicked on "server data" in the window that opens when you click on "folder size"). And now it works...

Can confirm, right click the account with search issues, Data File Properties... > Folder Size... > Server Data, try searching again, works fine...



I did this:

Outlook / File / Account settings / Doubleclick on the e-mailaddress / Disable the 'Cache' option. Or: slide the slider to 'All'.