Microsoft Exchange 2016 DAG Members addition issue from DR Site

%3CLINGO-SUB%20id%3D%22lingo-sub-388723%22%20slang%3D%22en-US%22%3EMicrosoft%20Exchange%202016%20DAG%20Members%20addition%20issue%20from%20DR%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-388723%22%20slang%3D%22en-US%22%3E%3CP%3EDear%20Friends%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20facing%20issue%20will%20adding%20DAG%20Members%20from%20DR%20Site%20in%20Stretch%20Cluster%20with%20IP%20Less%20DAG.%20The%20following%20are%20information%20of%20my%20Infrastructure%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDAG%20Configuration%3A%20%26nbsp%3B%20IP%20Less%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPrimary%20Site%3C%2FP%3E%3CP%3EAD%20Site%3A%20%26nbsp%3B%20Default%20Site%3C%2FP%3E%3CP%3EDomain%20Controllers%20Windows%20Server%202016%20%26nbsp%3B%20%26nbsp%3B%26nbsp%3B%202%3C%2FP%3E%3CP%3EExchange%202016%20Enterprise%20(Rollup%209)%26nbsp%3B%20on%20Windows%20Server%202016%20Standard%26nbsp%3B%20(Rollup%20August%26nbsp%3B%202018)%20%26nbsp%3B%202%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDR%20Site%3A%3C%2FP%3E%3CP%3EAD%20Site%3A%20%26nbsp%3B%26nbsp%3B%20XYZ%3C%2FP%3E%3CP%3EDomain%20Controller%20Windows%20Server%202016%20%26nbsp%3B%20%26nbsp%3B%26nbsp%3B%201%3C%2FP%3E%3CP%3EExchange%202016%20Enterprise%20(Rollup%209)%20on%20Windows%20Server%202016%20Standard%20(Rollup%20February%202019)%26nbsp%3B%202%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EReplication%20Network%20and%20MAPI%20Network%20routing%20is%20working%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20facing%20error%20while%20adding%20third%20and%20forth%20Node%20in%20DAG.%20the%20following%20error%20are%20occurred.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EError%20%23%201%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23000000%22%20face%3D%22Calibri%22%3EA%20server-side%20database%20availability%20group%20administrative%20operation%20failed.%20Error%20The%20operation%20failed.%20CreateCluster%20errors%20may%20result%20from%20incorrectly%20configured%20static%20addresses.%20Error%3A%20An%20error%20occurred%20while%20attempting%20a%20cluster%20operation.%20Error%3A%20Cluster%20API%20failed%3A%20%22AddClusterNode()%20(MaxPercentage%3D100)%20failed%20with%200x5b4.%20Error%3A%20This%20operation%20returned%20because%20the%20timeout%20period%20expired%22.%20%5BServer%3A%20abc.domain.com%5D%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23000000%22%20face%3D%22Calibri%22%3EError%20%23%202%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23000000%22%20face%3D%22Calibri%22%3EThe%20following%20servers%20have%20been%20added%20to%20the%20database%20availability%20group%20but%20not%20to%20the%20cluster%3A%20abc.domain.com.%20This%20is%20usually%20the%20result%20of%20an%20error%20during%20membership%20change.%20Removing%20and%20re-adding%20the%20servers%20can%20correct%20the%20issue.%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23000000%22%20face%3D%22Calibri%22%3EPlease%20help%20me%20out%20as%20I%20am%20trying%20to%20resolve%20this%20issue%20but%20till%20now%20there%20is%20no%20success.%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23000000%22%20face%3D%22Calibri%22%3ERegards%2C%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23000000%22%20face%3D%22Calibri%22%3ENadeem%20Afzal%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-388723%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%202016%20DAG%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-389216%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Exchange%202016%20DAG%20Members%20addition%20issue%20from%20DR%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-389216%22%20slang%3D%22en-US%22%3E%3CP%3EDear%26nbsp%3B%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20issue%20has%20been%20resolved%2C%20which%20was%20due%20to%20ports%20blocking%20between%20two%20Sites.%20The%20following%20ports%20were%20blocked%20at%20network%20level%3C%2FP%3E%3CP%3EDAG%20Replication%20Port%20%26nbsp%3B%2064327%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENadeem%20Afzal%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Dear Friends,

 

I am facing issue will adding DAG Members from DR Site in Stretch Cluster with IP Less DAG. The following are information of my Infrastructure

 

DAG Configuration:   IP Less

 

Primary Site

AD Site:   Default Site

Domain Controllers Windows Server 2016      2

Exchange 2016 Enterprise (Rollup 9)  on Windows Server 2016 Standard  (Rollup August  2018)   2

 

DR Site:

AD Site:    XYZ

Domain Controller Windows Server 2016      1

Exchange 2016 Enterprise (Rollup 9) on Windows Server 2016 Standard (Rollup February 2019)  2

 

Replication Network and MAPI Network routing is working fine.

 

I am facing error while adding third and forth Node in DAG. the following error are occurred.

 

Error # 1

A server-side database availability group administrative operation failed. Error The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired". [Server: abc.domain.com]

 

Error # 2

The following servers have been added to the database availability group but not to the cluster: abc.domain.com. This is usually the result of an error during membership change. Removing and re-adding the servers can correct the issue.

 

Please help me out as I am trying to resolve this issue but till now there is no success.

Regards,

Nadeem Afzal

 

1 Reply
Highlighted

Dear  All,

 

My issue has been resolved, which was due to ports blocking between two Sites. The following ports were blocked at network level

DAG Replication Port   64327

 

Regards,

 

Nadeem Afzal