IMCEAEX NDRs 50% solved - Exchange 2013

Copper Contributor



After DB corruption and re-creating two mailbox accounts, adding new X500 email address entries (based on email NDRs "mailto:" fields) and deleting cached contact information in outlook clients, I've ended up with a functional account  and  the other account (let's say not being able to receive emails.

The weird thing is, outlook clients are caching the contact with a typo from somewere I'm not being able to find nor fix. Even weirder, users are able to send emails for a first time if they delete cached contact information and then type the email address manually, but on a second attempt they receive a NDR message with the wrong X500 email address.

Exchange side X500 entry:
/o=corp123/ou=Exchange Administrative Group (FYDIBOHF4141415)/cn=Recipients /


Outlook NDR:

/o=corp123/ou=Exchange Administrative Group (FYDIBOHF4141415)/cn=Recipients /


I've restarted several services and tried restarting the server. No luck.


Did I missed something when re-creating the mailboxes in the Exchange Server?


Thanks in advance!


4 Replies

Based on many posts I've been reading, I modified the X500 entry by removing the "".


/o=corp123/ou=Exchange Administrative Group (FYDIBOHF4141415)/cn=Recipients /

/o=corp123/ou=Exchange Administrative Group (FYDIBOHF4141415)/cn=Recipients /cn=ABC



Now the NDR emails shows the following :(
/o=corp123/ou=Exchange Administrative Group (FYDIBOHF4141415)/cn=Recipients /cn=ABzC


User's DN appears to be OK within AD.

Any ideas?


@marguelles, have you seen this kb?

It might not be your exact scenario, but just imagine the big underlying theme is having some but not all recipients present in the local Exchange org where the ndr is being generated.

In my experience, Exchange servers add the @domain onto the end of the legacyExchangeDN / x500 when they can't find that recipient in the local directory. But the @domain only shows in the ndr, not on the actual ldn/x500 being searched for.

Not sure if this will help but figured I'd throw it out there just in case.

Hi @Jeremy Bradshaw,


Apparently, the issue got resolved by removing the from the X500 entry!

Thanks for your answer!


Glad it helped!