Federation Trust in Hybrid Exchange

Copper Contributor


we have a Hybrid Exchange environment in 'Full Hybrid' configuration. The on-premises setup consists of one Exchange 2016 server.


I noticed several recurring errors in the application log of the on-premises exchange server.
source: MSExchange Common, event id 401, level: error

The organization certificate named '618F92187B527A8EDEA1C4C763F8B8BA0CAFE413' in the Federation Trust object 'Microsoft Federation Gateway' cannot be found in the computer's certificate store. Please review the Federation Trust properties and the certificates present in the certificate store of the server.


as well as:

source: MSExchange Certificate Deployment, event id 2005, level: warning

Federation or Auth certificate not found: 618F92187B527A8EDEA1C4C763F8B8BA0CAFE413. Unable to find the certificate in the local or neighboring sites. Confirm that the certificate is available in your topology and if necessary, reset the certificate on the Federation Trust to a valid certificate using Set-FederationTrust or Set-AuthConfig. The certificate may take time to propagate to the local or neighboring sites.


I have been able to verify that the missing certificate does not exist in the certificate store. The server does have a certificate named 'Microsoft Exchange Server Auth Certificate" in the certificate store but its thumb print does not match the one mentioned in the event log error.


When I run get-FederationTrust | fl, I'm getting


[PS] C:\Windows\system32>get-FederationTrust | fl

RunspaceId                   : 62c9c6bb-0393-45e4-a24c-e3071bb585fc
ApplicationIdentifier        : 0000000040057966
ApplicationUri               : FYDIBOHF25SPDLT.***.com
OrgCertificate               : [Subject]


                               [Serial Number]

                               [Not Before]
                                 9/16/2018 1:43:36 PM

                               [Not After]
                                 9/16/2023 1:43:36 PM


OrgNextCertificate           :
OrgPrevCertificate           :
OrgPrivCertificate           : 618F92187B527A8EDEA1C4C763F8B8BA0CAFE413



The solution should be obvious: I need to replace the federation trust certificate. This is where things get interesting:


I'm working with the document Replace an expired federation certificate. As I mentioned above, a new certificate already exists in the store. I need to update the federation trust to use the new certificate. As per instructions, I need to remove all federated domains first.


[PS] C:\Windows\system32>Remove-FederatedDomain -DomainName ***.com -Force

Are you sure you want to perform this action?
Removing federated domain "***.com on organization "***".
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [?] Help (default is "Y"):
Federation certificate with the thumbprint "618F92187B527A8EDEA1C4C763F8B8BA0CAFE413" cannot be found.
    + CategoryInfo          : InvalidResult: (:) [Remove-FederatedDomain], FederationCertificateInvalidException
    + FullyQualifiedErrorId : [Server=MAIL5,RequestId=4a9693d0-4723-444b-a44b-0fa9a118f487,TimeStamp=7/12/2021 12:29:0
   2 PM] [FailureCategory=Cmdlet-FederationCertificateInvalidException] CE320263,Microsoft.Exchange.Management.System
    + PSComputerName        : mail5.***.local

[PS] C:\Windows\system32>



This fails and it turns out that if the federation trust certificate is missing, the trust cannot be edited anymore at all. This is explained here: Error when you make changes to federation trust: Federation certificate with the thumbprint cannot b...

The solution is to remove the trust manually using ADSI editor and then recreate the trust. I deleted the trust as per instructions and indeed it now shows:


[PS] C:\Windows\system32>get-FederationTrust
[PS] C:\Windows\system32>



Next, I tried to recreate the federation trust and my understanding was that the Hybrid Configuration Wizard would take care of that. I'm also fairly certain that HCW created the trust in the first place when I set up the hybrid environment. HCW does not recreate the trust. It runs without errors but it does not create the federation trust.


Then I found this: March 2020 significant update to Hybrid Configuration Wizard 

HCW will no longer enable Federation Trust by default for all installations. Instead, it will only enable Federation Trust if there are Exchange 2010 servers on premises. HCW will call Get-ExchangeServer and if no Exchange 2010 servers are reported, the workflow to enable Federation Trust and subsequently require domain proof will not execute. Note that organization relationships are still created.

In our network, there are no Exchange 2010 servers left on premises.


My question is: Is the federation trust still needed in Hybrid Exchange? Should I attempt to recreate federation trust using these instructions: Configure a federation trust: Exchange 2013 Help | Microsoft Docs


Additionally, I'm currently in the process of verifying if everything to do with Hybrid Exchange still works now that the federation trust has been removed (free/busy, mail flow, live migrations etc.)

6 Replies

Hi @Siegfried_Beitl1090 


Any progress with this issue? We have the same problem as you with 'Microsoft Federation Gateway'. Just wondering if you could resolve the problem?



Same question here... subbed

Same scenario as well. Need to know if its needed.

WIth modern Exchange Server (2013+) you do not use the classic federation model anymore. Instead you use Hybrid Modern Authentication (HMA) utilizing the Azure AD AppPrincipal configuration.

You can find more information on the required HMA setup here.


So is there any final statement if we still need the federation trust ? I think it was superseded by organization-relationship?
hello guys, i made a renewal of federation certificate but when i make a test with valid email address I'm getting an error and showing that there is federation trust.

i appreciate any help