Failed to move mailbox from EX2013 DB to EX2019DB Transient error - anyone have a solution?

Brass Contributor



I am at my last mailbox to transfer from my EX2013 server to my EX2019 Server.

All my mailbox transfers went well, and I've had a few of similar size. This particular mailbox is becoming problematic for me because every time it fails it puts the mailbox in quarantine and I have to remove it from quarantine via Regedit (HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-{db guid}\QuarantinedMailboxes\{mailbox guid}).

I also cannot seem to move this mailbox via the ECP for some reason when I create a move request in the ECP nothing happens. The mailbox never shows up in the migration status and the job eventually completes but nothing gets done (no idea why).


I am doing it via powershell with this command:

New-MoveRequest -Identity 'Useremailaddress' -TargetDatabase "EX2019DBName"


But it always fails (twice now) with the below error:

The job encountered too many transient failures (122) and is quitting. The most common failure is StorageTransientException with the hit count 60. As far as I can tell, it fails at 17GB of 43GB. I cannot confirm but I think the last time it failed at the same place. 


I also used this command to try and repair the mailbox but it repaired it in seconds so I assume it didn't do anything (I didn't do this the second time it failed):


  • New-MailboxRepairRequest -Mailbox xyz -CorruptionType ProvisionedFolder,SearchFolder,AggregateCounts,FolderView -Archive

Is there anything I can do on this mailbox 

1) Without knocking it down?

2) Via the powershell (maybe modify PS line I'm using)?


Is the error here stating that I have too many bad items? Is there anyway I can up the hit count from 60 to something else?


If I were to do this via ECP I would normally put the bad items at 500 or 1000 (but I don't know if this is the actual error). Other than this the Exchange services are running smoothly. 


Thank you very much for this early morning post / replies!

10 Replies
Has anyone come across this kind of error or any kind of fix to it?
Still looking for a potential answer to this
Kindly run the following command and share the output file in PM
Get-MoveRequestStatistics -Identity -IncludeReport | Export-CliXML
I will try this command again, I tried it the first time and it asked me for input (i assume it was for the export path but it didn't work)
Export-CliXML : Access to the path 'C:\temp' is denied

No matter what I put as the path it's always access is denied.
Never encountered this in the wild. Have you tried an offline move - if possible. User will not be able to access it when it's moved. Error mentions transient, implying you should be able to retry later point in time. Also, the export Suraj suggested, you are receiving this message because you are running the Exchange Management Shell un-elevated/non-local admin and have no perms in that folder. Could use ... | Export-Clixml (Join-Path $ENV:TEMP 'out.xml') - xml should be in your own temp folder.

Hello again, I tried again to move the mailbox. I tried to move it after a repair to the same database on the new server which it died again at 53%.I then tried to create a new database on the same old exchange server and tried to move it. This time I was able to get to 89% (41.67gb of 44.83 gb) and it stalled. The error message is the following


Error: Cannot open mailbox /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=OLD_SERVER/cn=Microsoft System Attendant. --> MapiExceptionMailboxQuarantined: Unable to open message store. (hr=0x80004005, ec=2611) Diagnostic context: Lid: 55847 EMSMDBPOOL.EcPoolSessionDoRpc called [length=132]
Lid: 43559 EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=232][latency=0]
Lid: 52176 ClientVersion: 15.0.1497.12
Lid: 50032 ServerVersion: 15.0.1497.6012
Lid: 23226 --- ROP Parse Start ---
Lid: 27962 ROP: ropLogon [254]
Lid: 17082 ROP Error: 0xA33
Lid: 26937
Lid: 21921 StoreEc: 0xA33
Lid: 27962 ROP: ropExtendedError [250]
Lid: 1494 ---- Remote Context Beg ----
Lid: 50608
Lid: 32848 dwParam: 0x14
Lid: 61416 StoreEc: 0xA33
Lid: 56872 dwParam: 0xFE
Lid: 42712 StoreEc: 0xA33
Lid: 10786 dwParam: 0x0 Msg: 15.00.1497.012:OLD_SERVER
Lid: 1750 ---- Remote Context End ----
Lid: 26849
Lid: 21817 ROP Failure: 0xA33
Lid: 26297
Lid: 16585 StoreEc: 0xA33
Lid: 32441
Lid: 1706 StoreEc: 0xA33
Lid: 24761
Lid: 20665 StoreEc: 0xA33
Lid: 25785
Lid: 29881 StoreEc: 0xA33


As far as I can tell the move is stalling because the mailbox is put into quarantine for some unknown reason. I am unsure why this mailbox is being flagged as poisoned and the move stalls. I also don't understand why it is stalling at different percentages when I'm moving it to different databases. Normally, I wouldn't care about this kind of error but not being able to move this mailbox is stopping me from closing this server and I'm beginning to lose patience. Any help would be really appreciated. 

I was able to extract based off your other powershell command and the entire contents of the CSV are the following

12/12/2021 5:04:22 AM [NEW_SERVER] The Microsoft Exchange Mailbox Replication service 'NEW_SERVER' (15.2.986.9 caps:3FFFFF) is examining the request.
12/12/2021 5:04:22 AM [NEW_SERVER] Connected to target mailbox '8a529147-ba88-4d83-a744-73c67773ff54 (Primary)'
12/12/2021 5:04:22 AM [NEW_SERVER] Transient error StorageTransientException has occurred. The system will retry (121/1480).
12/12/2021 5:04:52 AM [NEW_SERVER] The Microsoft Exchange Mailbox Replication service 'NEW_SERVER' (15.2.986.9 caps:3FFFFF) is examining the request.
12/12/2021 5:04:52 AM Connected to target mailbox '8a529147-ba88-4d83-a744-73c67773ff54 (Primary)'
12/12/2021 5:04:52 AM The job encountered too many transient failures (122) and is quitting. The most common failure is StorageTransientException with the hit count 60.
The error is MAPIFailure
I am also googling the error ROP Failure: 0xA33 and I keep coming up with something to the effect of "not enough space on the drive"

For reference, the mailbox is located on a database that has 94.4GB free of 1.47TB and the target database (where I want to move this mailbox) has 476 GB free of 741GB.

Interestingly enough, the target database didn't delete the move so there is a 42GB EDB and all the log files (I do not enable circular logging on the databases) 

I dismounted the mailbox database and the end user mailbox still works so I know these files are not being used.

EDIT: When I dismounted the database and deleted the files on the target database the size of the files was 83GB (42GB for the EDB and 41GB of log files). I don't know if that means anything.

I am indeed at a loss.