Exchange Server 2019 Installation Fails with too many prerequisites check errors!

Brass Contributor

Hi Brain Trust, 

 

I'm trying to install Exchange 2019 server to replace my current Exchange 2013 server. I have all required permissions (Schema Admin, Enterprise Admin, Organization Management etc etc..) in the current environment and the Domain, Forest Functional levels are 2012 R2 as well. When I'm trying to run the exchange setup, the prerequisite check fails with a load of errors! 

 

Our AD environment is very simple. Single domain with about 6 DCs. 

Does anyone have an idea what could be causing this?

Errors ---------------

 

Error:
The Active Directory schema isn't up-to-date, and this user account isn't a member of the 'Schema Admins' and/or 'Enterprise Admins' groups.
 
Error:
Global updates need to be made to Active Directory, and this user account isn't a member of the 'Enterprise Admins' group.
 
Error:
The local domain needs to be updated. You must be a member of the 'Domain Admins' group and 'Organization Management' role group, or 'Enterprise Admins' group to continue.
 
Error:
You must be a member of the 'Organization Management' role group or a member of the 'Enterprise Admins' group to continue.
 
Error:
You must use an account that's a member of the Organization Management role group to install or upgrade the first Mailbox server role in the topology.
 
Error:
You must use an account that's a member of the Organization Management role group to install the first Client Access server role in the topology.
 
Error:
You must use an account that's a member of the Organization Management role group to install the first Client Access server role in the topology.
 
Error:
You must use an account that's a member of the Organization Management role group to install or upgrade the first Mailbox server role in the topology.
 
Error:
You must use an account that's a member of the Organization Management role group to install or upgrade the first Client Access server role in the topology.
 
Error:
Setup encountered a problem while validating the state of Active Directory: Exchange organization-level objects have not been created, and setup cannot create them because the local computer is not in the same domain and site as the schema master.  Run setup with the /prepareAD parameter on a computer in the domain astc and site Depot, and wait for replication to complete.  See the Exchange setup log for more information on this error.
 
Error:
The forest functional level of the current Active Directory forest is not Windows Server 2012 R2 or later. To install Exchange Server 2019, the forest functional level must be at least Windows Server 2012 R2.
 
Error:
Either Active Directory doesn't exist, or it can't be contacted.
 
Warning:
Setup will prepare the organization for Exchange Server 2019 by using 'Setup /PrepareAD'. No Exchange Server 2016 roles have been detected in this topology. After this operation, you will not be able to install any Exchange Server 2016 roles.
 
1 Reply
Try logging in using the Administrator account first created in Active Directory Server!