Exchange Online EWS Access

%3CLINGO-SUB%20id%3D%22lingo-sub-2340100%22%20slang%3D%22en-US%22%3EExchange%20Online%20EWS%20Access%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2340100%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20have%20been%20having%20issues%20in%20getting%20EWS%20working%20with%20Exchange%20online%20each%20time%20i%20go%20to%20%3CA%20href%3D%22https%3A%2F%2Foutlook.office365.com%2Fews%2Fexchange.asmx%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Foutlook.office365.com%2Fews%2Fexchange.asmx%3C%2FA%3E%26nbsp%3Bi%20get%20a%20blank%20page%20and%20when%20I%20run%20developer%20tools%20in%20IE%20i%20see%20a%20503%20error.%20Our%20ADFS%20is%20not%20externally%20accessible%20and%20we%20are%20currently%20using%20password%20hash%20sync%20in%20staged%20mode%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20try%20with%20a%20pure%20cloud%20account%20i%20get%20the%20xml%20service%20page%20in%20IE%20but%20not%20if%20i%20use%20my%20Azure%20synced%20account.%20Anyone%20come%20across%20this%20issue%3F%2C%20microsoft%20support%20have%20been%20investigating%20for%20the%20last%20few%20months%20with%20no%20joy.%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EVin%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2340100%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Ehybrid%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2341597%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%20Online%20EWS%20Access%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2341597%22%20slang%3D%22en-US%22%3EShould%20work%20fine%20with%20AD%20FS%2C%20but%20make%20sure%20basic%20authentication%20is%20enabled.%20Or%20better%20yet%20use%20Oauth%20if%20possible.%3C%2FLINGO-BODY%3E
Visitor

Hi,

I have been having issues in getting EWS working with Exchange online each time i go to https://outlook.office365.com/ews/exchange.asmx i get a blank page and when I run developer tools in IE i see a 503 error. Our ADFS is not externally accessible and we are currently using password hash sync in staged mode

 

If I try with a pure cloud account i get the xml service page in IE but not if i use my Azure synced account. Anyone come across this issue?, microsoft support have been investigating for the last few months with no joy.

Thanks,

Vin

1 Reply
Should work fine with AD FS, but make sure basic authentication is enabled. Or better yet use Oauth if possible.