Home

Exchange Management Shell not opening in Exchange Server 2019 on Windows Server 2019

%3CLINGO-SUB%20id%3D%22lingo-sub-751324%22%20slang%3D%22en-US%22%3EExchange%20Management%20Shell%20not%20opening%20in%20Exchange%20Server%202019%20on%20Windows%20Server%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-751324%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20a%20new%20installation%20of%20Exchange%20Server%202019%20CU2%20on%20Windows%20Server%202019%20fully%20patched%2C%20with%20.NET%20Framework%204.7.2%2C%26nbsp%3B%20the%20Exchange%20Management%20Shell%20is%20not%20connecting%20to%20Exchange%20with%20this%20error%20%3A%3C%2FP%3E%3CP%3E%22New-PSSession%20%3A%20%5Bserver.domain.com%5D%20Processing%20data%20from%20remote%20server%20server.domain.com%20failed%20with%20the%20following%20error%20message%3A%20%5BClientAccessServer%3DSERVER%2CBackEndServer%3Dserver.domain.com%2CRequestId%3D29e42dd0-3fd1-4787-%3CBR%20%2F%3Ea68c-20a70846c584%2CTimeStamp%3Ddd%2Fmm%2Fyyyy%20hh%3Amm%3Ass%5D%20%5BFailureCategory%3DWSMan-Others%5D%20Unable%20to%20load%20the%20assembly%20%22Microsoft.Exchange.Configuration.ObjectModel.dll%22%20specified%20in%20the%20%22InitializationParameters%22%20section.%20For%20more%20information%2C%20see%20the%20about_Remote_Troubleshooting%20Help%20topic.%26nbsp%3B%3CBR%20%2F%3EAt%20line%3A1%20char%3A1%3CBR%20%2F%3E%2B%20New-PSSession%20-ConnectionURI%20%22%24connectionUri%22%20-ConfigurationName%20Micr%20...%3CBR%20%2F%3E%2B%20CategoryInfo%20%3A%20OpenError%3A%20(System.Manageme....RemoteRunspace%3ARemoteRunspace)%20%5BNew-PSSession%5D%2C%20PSRemotingTransportException%3CBR%20%2F%3E%2B%20FullyQualifiedErrorId%20%3A%20IncorrectProtocolVersion%2CPSSessionOpenFailed%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20this%20error%2C%20EMS%20is%20able%20to%20connect%20to%20an%20old%20Exchange%202013%20server%20in%20coexistence%20in%20the%20same%20domain.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESomeone%20else%20experienced%20the%20same%20problem%3F%26nbsp%3B%20Could%20be%20a%20bug%20in%20Exchange%202019%20CU2%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-751324%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873276%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%20Management%20Shell%20not%20opening%20in%20Exchange%20Server%202019%20on%20Windows%20Server%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873276%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30851%22%20target%3D%22_blank%22%3E%40Ivan%20Salvade'%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20experiencing%20the%20same%20problem%20with%20Exchange%202016%20on%20Server%202016%20on%20a%20child%20domain.%20My%20root%20domain%20is%20running%20Exchange%202016%20and%20I%20had%20no%20issues%20when%20I%20migrated%20from%202010%20to%202016.%20When%20I%20install%20a%20new%20Exchange%202016%20(CU%2013)%20server%20in%20the%20child%20domain%20I%20have%20run%20into%20this%20problem%20you%20are%20describing%20for%202019%20editions%20respectively.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20yo%20manage%20to%20find%20a%20solution%2Fcause%20for%20your%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873378%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%20Management%20Shell%20not%20opening%20in%20Exchange%20Server%202019%20on%20Windows%20Server%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873378%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F380465%22%20target%3D%22_blank%22%3E%40Matt_B010%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%E2%80%A6%20reinstalled%20entire%20server%20to%20resolve%20%3A(%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873423%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%20Management%20Shell%20not%20opening%20in%20Exchange%20Server%202019%20on%20Windows%20Server%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873423%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F380465%22%20target%3D%22_blank%22%3E%40Matt_B010%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ECan%20you%20try%20to%20run%20%22Set-ExecutionPolicy%20Unrestricted%22%20in%20PowerShell%20in%20Run%20As%20Administrator%20and%20after%20run%20Exchange%20Powershell%20in%20Run%20Ad%20Administrator%20as%20well%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873440%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%20Management%20Shell%20not%20opening%20in%20Exchange%20Server%202019%20on%20Windows%20Server%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873440%22%20slang%3D%22en-US%22%3ETried%20that%20yesterday%20and%20it%20didn't%20work%20either.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873441%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%20Management%20Shell%20not%20opening%20in%20Exchange%20Server%202019%20on%20Windows%20Server%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873441%22%20slang%3D%22en-US%22%3ETried%20that%20too%20and%20it%20didn't%20work.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873466%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%20Management%20Shell%20not%20opening%20in%20Exchange%20Server%202019%20on%20Windows%20Server%202019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873466%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30851%22%20target%3D%22_blank%22%3E%40Ivan%20Salvade'%3C%2FA%3E%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50%22%20target%3D%22_blank%22%3E%40Nuno%20Silva%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESolved.%3C%2FP%3E%3CP%3ETurns%20out%20there%20was%20a%20GPO%20in%20the%20child%20domain%20being%20applied%20at%20a%20higher%20precedence%20that%20had%20over%20written%20the%20Default%20Domain%20controllers%20policy%20under%2C%3C%2FP%3E%3CP%3EC%3CSPAN%3Eomputer%20Configuration%5CWindows%20Settings%5CSecurity%20Settings%5CLocal%20Policies%5CUser%20Rights%20Assignment%5C%20Manage%20auditing%20and%20security%20log%20was%20missing%20the%20%22Exchange%20Servers%22%20group.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EAdded%20the%20group%2C%20ran%20gpupdate%20and%20the%20Exchange%20Management%20Shell%20now%20connects.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%20for%20the%20quick%20replies.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Ivan Salvade'
New Contributor

In a new installation of Exchange Server 2019 CU2 on Windows Server 2019 fully patched, with .NET Framework 4.7.2,  the Exchange Management Shell is not connecting to Exchange with this error :

"New-PSSession : [server.domain.com] Processing data from remote server server.domain.com failed with the following error message: [ClientAccessServer=SERVER,BackEndServer=server.domain.com,RequestId=29e42dd0-3fd1-4787-
a68c-20a70846c584,TimeStamp=dd/mm/yyyy hh:mm:ss] [FailureCategory=WSMan-Others] Unable to load the assembly "Microsoft.Exchange.Configuration.ObjectModel.dll" specified in the "InitializationParameters" section. For more information, see the about_Remote_Troubleshooting Help topic. 
At line:1 char:1
+ New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Micr ...
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotingTransportException
+ FullyQualifiedErrorId : IncorrectProtocolVersion,PSSessionOpenFailed

 

After this error, EMS is able to connect to an old Exchange 2013 server in coexistence in the same domain.

 

Someone else experienced the same problem?  Could be a bug in Exchange 2019 CU2?

 

Thank you

 

6 Replies
Highlighted

@Ivan Salvade' 

I am experiencing the same problem with Exchange 2016 on Server 2016 on a child domain. My root domain is running Exchange 2016 and I had no issues when I migrated from 2010 to 2016. When I install a new Exchange 2016 (CU 13) server in the child domain I have run into this problem you are describing for 2019 editions respectively.

 

Did yo manage to find a solution/cause for your issue?

Highlighted

@Matt_B010 

 

No… reinstalled entire server to resolve :(

Highlighted

Hi @Matt_B010,

 

Can you try to run "Set-ExecutionPolicy Unrestricted" in PowerShell in Run As Administrator and after run Exchange Powershell in Run Ad Administrator as well ?

Highlighted
Tried that yesterday and it didn't work either.
Highlighted
Highlighted

@Ivan Salvade'  @Nuno Silva 

Solved.

Turns out there was a GPO in the child domain being applied at a higher precedence that had over written the Default Domain controllers policy under,

Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\ Manage auditing and security log was missing the "Exchange Servers" group.

 

Added the group, ran gpupdate and the Exchange Management Shell now connects.

Thanks for the quick replies.