Exchange Hybrid Wizard stuck at Adding Federated Domain

Bronze Contributor

So, we trying to setup a full hybrid configuration between our Exchange 2013 onPrem and Office 365.

Unfortunately we're stuck a "Adding Federated Domain". This is the step that follows after verifying the TXT record.

I've left it running over the weekend, but still nothing. Tried it today today again, same result.

Unfortunately I wasn't able to find any helpful log entries. Am I missing something?

The Exchange Connectivity Analyzer runs through just fine to our onPrem environment.

3 Replies
best response confirmed by VI_Migration (Silver Contributor)
Had the issue solved with the help of Microsoft CSP Support, since our CSP also wasn't able to solve the issue.
For those interested, since there isn't much about this specific error on the web:

Issue 1 - Timezone
It looks like the logs recommend you to have your AD Servers and the Exchange Server (where we've run the Hybrid Wizard) set to the UTC Timezone. Not sure if this is really needed, but it was highlighted as an error in the hybrid wizard log

Issue 2 - DNS Lookup
Even though our TXT record for verification was properly set, all parties where unaware, that the specific DNS Server that hosted our DNS records (external provider) was stuck and didn't really resolve the DNS lookup from the Hybrid Wizard. Our provider had to restart their DNS services, after that everything worked again.
Really interesting collection of issues Ivan - thanks for posting!
Thanks for sharing the solution!