Exchange Federation Certificate

Copper Contributor

Hi,

I have an Exchange 2016 server, everything is working fine, but since a few month a Federation certificate have expired, I don't have any problem when the certificate expired, but I have a warning on the ECP and I'm trying to fix it to clear that warning, even if the certificate is not really use.

The Exchange Server is full standalone, no hybrid scenario.

I have tried to follow the step from MS site, but it doesn't work.

this cmdlet gives no output :

Get-FederatedOrganizationIdentifier | Format-List AccountNamespace,Domains

AccountNamespace :

Domains :

Get-FederationTrust

Name ApplicationIdentifier ApplicationUri

Microsoft Federat...

 

It seems like I have the certificate but no a real federation set up for my domain, but it's normal because I don't use exchange online at all right ?

 

I have tried to bind a new federation certificate but I have this error :

Set-FederationTrust -Identity "Microsoft Federation Gateway" -Thumbprint XXX -RefreshMetaData

Certificate cannot be updated until federation approval is configured with STS.

I'm stuck :(

Do you have any idea how I can fix this ?

 

2 Replies
Generally speaking, federation can be used for free/busy sharing across Exchange organizations, it's not necessarily needed for the cloud only. If the error bothers you that much and you are sure you don't need the functionality, just do a Remove-FederationTrust. You can then recreate it as needed.

@VasilMichev  Hi,

I want to thanks for your reply, I have deleted the Trust with GUI and recreate it it's OK ;)