Exchange 2019 - TransportRules with Regular Expression

%3CLINGO-SUB%20id%3D%22lingo-sub-1480575%22%20slang%3D%22en-US%22%3EExchange%202019%20-%20TransportRules%20with%20Regular%20Expression%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1480575%22%20slang%3D%22en-US%22%3E%3CP%3EAfter%20migrating%20from%20Exchange%202016%20with%20EDGE%20server%20to%20Exchange%202019%2C%20we%20have%20problems%20with%20transport%20rules.%20Here%20are%20the%20transport%20rules%20we%20use%3A%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3ENew-TransportRule%20-Name%20%22Wildcard%22%20-AnyOfRecipientAddressMatchesPatterns%20%22%5Esome-pretext%5Cw*%40(mymaildomain.com)%24%22%20-RedirectMessageTo%20some-mailbox%40mymaildomain.com%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%3CBR%20%2F%3EWe%20would%20like%20to%20continue%20using%20the%20transport%20rule%2C%20but%20we%20receive%20an%20NDR%20reply%20with%20Reciepient%20not%20found.%20The%20RecipientFilterConfig%20was%20deactivated%20with%20%3A%20Set-RecipientFilterConfig%20-Enabled%20%24false%3CBR%20%2F%3EThese%20transport%20rules%20do%20not%20work%20on%20Exchange%20Online%20either.%3CBR%20%2F%3EDeactivating%20the%20TransportAgent%20with%20Disable-TransportAgent%20%22Recipient%20Filter%20Agent%22%20does%20not%20help%20us%20because%20there%20is%20none%20installed.%3CBR%20%2F%3EPerhaps%20I%20have%20missed%20something%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1480575%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHybrid%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

After migrating from Exchange 2016 with EDGE server to Exchange 2019, we have problems with transport rules. Here are the transport rules we use:

New-TransportRule -Name "Wildcard" -AnyOfRecipientAddressMatchesPatterns "^some-pretext\w*@(mymaildomain.com)$" -RedirectMessageTo some-mailbox@mymaildomain.com


We would like to continue using the transport rule, but we receive an NDR reply with Reciepient not found. The RecipientFilterConfig was deactivated with : Set-RecipientFilterConfig -Enabled $false
These transport rules do not work on Exchange Online either.
Deactivating the TransportAgent with Disable-TransportAgent "Recipient Filter Agent" does not help us because there is none installed.
Perhaps I have missed something?

0 Replies