Exchange 2019 ECP broken after update

New Contributor

Dear all,

 

We currently have a hybrid setup with a Exchange Server 2019 used only for mgmt purposes, and recently CU12 has been installed, and seemed to be working well immediately after the upgrade was done. 

After a few days, when I tried to logon to the EAC, it seems to be broken, the layout is gone and clicking on something simply brings me to the login page.
I have run the updatecas and updateconfig ps1 files, but that did not resolved the issue.
The Exchange powershell is still working which leads me to think it might be something in ISS or a config file somewhere got corrupt perhaps?

Has anybody any idea what might the be the cause of this, and how to resolve it?

It looks like this currently.
ECP error.png

2 Replies

@BDO_BvB 
What is the result, when you access the ECP using the configured Exchange namespace FQDN, e.g. https://mail.something.tld/ecp?

It seems that the browser does not load the CSS files.

Do you see any errors in the event log of the server?

Does the IIS binding for the default website contain more than one TCP 443 binding?

What does the IIS W3SVC log file tell you? Do you see any errors accessing CSS files?

 

 

 

@Thomas Stensitzki 
Thomas thank you already for the reply.

If I use the link as you mentioned, same result. A broken page.
There is only 1 port 443 binding on the default website
I don't really see any obvious errors in the W3SVC log file, but not sure what I should be looking for.
Eventviewer doesn't really contain errors for Exchange or the Web server logs.

Is there a way to rebuild the CSS files?