Home

Exchange 2016 Incoming & Outgoing Messages Delay

%3CLINGO-SUB%20id%3D%22lingo-sub-268311%22%20slang%3D%22en-US%22%3EExchange%202016%20Incoming%20%26amp%3B%20Outgoing%20Messages%20Delay%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-268311%22%20slang%3D%22en-US%22%3E%3CP%3EDears%2C%3C%2FP%3E%3CP%3EI%20have%20a%20big%20Delay%20in%20Incoming%20and%20Outgoing%20Messages%20in%20Exchange%202016.%3C%2FP%3E%3CP%3ESometimes%20the%20messages%20are%20delivered%20whiten%20seconds%20and%20sometimes%20take%20more%20than%20one%20Hour%20which%20makes%20me%20crazy.%3CBR%20%2F%3ESo%20i%20shared%20this%20issue%20with%20the%20people%20here%20to%20find%20a%20solution%20for%20it.%3C%2FP%3E%3CP%3EKindly%20check%20the%20below%20Screen%20Shoot%20of%20One%20Message%20Header%20which%20took%2027%20Minutes%20to%20be%20sent.%3C%2FP%3E%3CP%3EDears%20this%20is%20a%20big%20issue%20for%20me%20%26amp%3B%20i%20need%20to%20solve%20it%20Asap%2C%20So%20i%20need%20someone%20to%20help.%3C%2FP%3E%3CP%3EThanks%20In%20Advance.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-268311%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2016%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270486%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%202016%20Incoming%20%26amp%3B%20Outgoing%20Messages%20Delay%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270486%22%20slang%3D%22en-US%22%3E%3CP%3EDear%20Mr%20Adam%2C%3C%2FP%3E%3CP%3EI%20appreciate%20your%20Support%2C%20just%20i%20need%20to%20ask%20if%20the%20delay%20is%20made%20by%20this%20error%20or%20something%20else%3F%3C%2FP%3E%3CP%3EI%20mean%20is%20TLS%20issue%20made%20the%20delay%20or%20not%20%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270439%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%202016%20Incoming%20%26amp%3B%20Outgoing%20Messages%20Delay%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270439%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Again%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20additional%20details.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%22An%20TLS%201.2%20connection%20request%20was%20received%20from%20a%20remote%20client%20application%2C%20but%20none%20of%20the%20cipher%20suites%20supported%20by%20the%20client%20application%20are%20supported%20by%20the%20server%22%20really%20holds%20the%20key%20to%20me.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThe%20applications%2Fdevice%20you%20are%20using%20to%20send%20to%20your%20exchange%20server%20(be%20it%20outlook%2Fa%20printer%2Fwhatever)%2C%20is%20trying%20to%20use%20TLS%201.2.%20It%20is%20failing%20on%20the%20server%2C%20as%20the%20server%20is%20having%20issues%20translating%2Funderstanding%20the%20secure%20cipher%20that%20is%20being%20used%20by%20TLS%201.2.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20would%20guess%20this%20comes%20down%20to%20one%20of%20maybe%20a%20few%20things%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E1.%20Your%20SSL%20cert%20on%20the%20server%20may%20be%20out%20of%20date%20or%20wrong.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E2.%20You%20dont%20have%20TLS%201.2%20enabled%20on%20the%20server%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EIf%20you%20need%20to%20check%20if%20its%20on%20-%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fprevious-versions%2Fwindows%2Fit-pro%2Fwindows-server-2012-R2-and-2012%2Fdn786418(v%3Dws.11)%23BKMK_SchannelTR_TLS12%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fprevious-versions%2Fwindows%2Fit-pro%2Fwindows-server-2012-R2-and-2012%2Fdn786418(v%3Dws.11)%23BKMK_SchannelTR_TLS12%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EIf%20you%20need%20to%20turn%20it%20on%20-%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fblogs.technet.microsoft.com%2Fexchange%2F2018%2F04%2F02%2Fexchange-server-tls-guidance-part-2-enabling-tls-1-2-and-identifying-clients-not-using-it%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fblogs.technet.microsoft.com%2Fexchange%2F2018%2F04%2F02%2Fexchange-server-tls-guidance-part-2-enabling-tls-1-2-and-identifying-clients-not-using-it%2F%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20would%20start%20looking%20there%2C%20as%20the%20error%20clearly%20is%20telling%20you%20it%20is%20failing%20because%20the%20server%20is%20failing%20to%20read%20the%20TLS%201.2%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EGoodluck%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EAdam%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270358%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%202016%20Incoming%20%26amp%3B%20Outgoing%20Messages%20Delay%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270358%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20Dear%2C%3C%2FP%3E%3CP%3EThere%20are%20some%20error%20Logs%20i%20saw%20in%20Event%20Viewer%20if%20you%20can%20tell%20me%20what%20are%20the%20reasons%20behind%20them%20these%20Logs%20Are%20as%20below%3A%3C%2FP%3E%3CP%3E1-%20Event%20ID%3A36888%20%22A%20fatal%20alert%20was%20generated%20and%20sent%20to%20the%20remote%20endpoint.%20This%20may%20result%20in%20termination%20of%20the%20connection.%20The%20TLS%20protocol%20defined%20fatal%20error%20code%20is%2010.%20The%20Windows%20SChannel%20error%20state%20is%201203.%22%3C%2FP%3E%3CP%3E2-Event%20ID%3A36874%20%22An%20TLS%201.2%20connection%20request%20was%20received%20from%20a%20remote%20client%20application%2C%20but%20none%20of%20the%20cipher%20suites%20supported%20by%20the%20client%20application%20are%20supported%20by%20the%20server.%20The%20SSL%20connection%20request%20has%20failed.%22%3C%2FP%3E%3CP%3EPlease%20if%20you%20have%20any%20clarification%20about%20these%20two%20errors%20tell%20me.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-269929%22%20slang%3D%22en-US%22%3ERe%3A%20Exchange%202016%20Incoming%20%26amp%3B%20Outgoing%20Messages%20Delay%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-269929%22%20slang%3D%22en-US%22%3E%3CP%3EHello%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F224837%22%20target%3D%22_blank%22%3E%40IT%20null%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUnfortunately%20your%20screenshot%20does%20not%20show%20up%20to%20much.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20anyone%20is%20going%20to%20be%20able%20to%20conclude%20from%20that%20is%20that%20the%20message%20on%20the%20first%20hop%20was%20delayed%20for%2027%20mins.%20That%20just%20tells%20us%20that%20the%20one%20of%20the%20exchange%20servers%20in%20your%20system%20is%20being%20slow.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20first%20thing%20you%20need%20to%20do%20is%20this%3A%3C%2FP%3E%3CP%3E1.%20Check%20you%20message%20queue%20after%20sending%20a%20message%20that%20you%20know%20is%20delayed.%20Verify%20that%20it%20is%20there%2C%20and%20if%20it%20is%26nbsp%3Bcheck%20the%20property%20of%26nbsp%3Bstatus%20-%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Fmail-flow%2Fqueues%2Fqueued-message-properties%3Fview%3Dexchserver-2019%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Fmail-flow%2Fqueues%2Fqueued-message-properties%3Fview%3Dexchserver-2019%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E2.%20There%20is%20also%20a%20%22last%20error%22%20field%2C%20that%20with%20any%20luck%20can%20have%20more%20specific%20information%20for%20you.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBased%20on%20what%20the%20status%20is%2C%20that%20gives%20you%20a%20more%20direct%20path%20to%20try%20to%20resolve.%20If%20it%20is%20failing%2C%20that%20is%20different%20troubleshooting%20from%20queuing%2C%20or%20retrying%20for%20instance.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20you%20are%20lucky%2C%20there%20will%20be%20a%20clearly%20stated%20error%20as%20well.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20what%20you%20need%20to%20do%20is%20check%20what%20is%20happening%20to%20the%20message%20why%20it%20is%20in%20your%20queue.%20From%20there%20we%20can%20try%20to%20help%20further.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAdam%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
IT null
New Contributor

Dears,

I have a big Delay in Incoming and Outgoing Messages in Exchange 2016.

Sometimes the messages are delivered whiten seconds and sometimes take more than one Hour which makes me crazy.
So i shared this issue with the people here to find a solution for it.

Kindly check the below Screen Shoot of One Message Header which took 27 Minutes to be sent.

Dears this is a big issue for me & i need to solve it Asap, So i need someone to help.

Thanks In Advance.

4 Replies

Hello @IT null,

 

Unfortunately your screenshot does not show up to much. 

 

All anyone is going to be able to conclude from that is that the message on the first hop was delayed for 27 mins. That just tells us that the one of the exchange servers in your system is being slow.

 

The first thing you need to do is this:

1. Check you message queue after sending a message that you know is delayed. Verify that it is there, and if it is check the property of status - https://docs.microsoft.com/en-us/exchange/mail-flow/queues/queued-message-properties?view=exchserver...

 

2. There is also a "last error" field, that with any luck can have more specific information for you.

 

Based on what the status is, that gives you a more direct path to try to resolve. If it is failing, that is different troubleshooting from queuing, or retrying for instance.

 

If you are lucky, there will be a clearly stated error as well.

 

So what you need to do is check what is happening to the message why it is in your queue. From there we can try to help further.

 

Adam

 

 

 

 

Highlighted

My Dear,

There are some error Logs i saw in Event Viewer if you can tell me what are the reasons behind them these Logs Are as below:

1- Event ID:36888 "A fatal alert was generated and sent to the remote endpoint. This may result in termination of the connection. The TLS protocol defined fatal error code is 10. The Windows SChannel error state is 1203."

2-Event ID:36874 "An TLS 1.2 connection request was received from a remote client application, but none of the cipher suites supported by the client application are supported by the server. The SSL connection request has failed."

Please if you have any clarification about these two errors tell me.

 

 

Highlighted

Hello Again,

 

Thanks for the additional details.

 

"An TLS 1.2 connection request was received from a remote client application, but none of the cipher suites supported by the client application are supported by the server" really holds the key to me.

 

The applications/device you are using to send to your exchange server (be it outlook/a printer/whatever), is trying to use TLS 1.2. It is failing on the server, as the server is having issues translating/understanding the secure cipher that is being used by TLS 1.2.

 

I would guess this comes down to one of maybe a few things:

1. Your SSL cert on the server may be out of date or wrong.

2. You dont have TLS 1.2 enabled on the server:

If you need to check if its on - https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-R2-and-2012/dn...

If you need to turn it on - https://blogs.technet.microsoft.com/exchange/2018/04/02/exchange-server-tls-guidance-part-2-enabling...

 

I would start looking there, as the error clearly is telling you it is failing because the server is failing to read the TLS 1.2

 

Goodluck

Adam

Highlighted

Dear Mr Adam,

I appreciate your Support, just i need to ask if the delay is made by this error or something else?

I mean is TLS issue made the delay or not ? 

Related Conversations
SharePoint 2016 / sharepoint online
Share24x7 in SharePoint on
0 Replies
Office 365 domain using external email server
SimonNZ in Office 365 on
1 Replies
Group and User Mix-up
Ruby_Monday in Office 365 on
3 Replies
Multi table query
sundarzee in Access on
3 Replies
Ports
Rising Flight in Office 365 on
0 Replies