Exchange 2016 / 2019 demands to install a prerequisite on an OS not supported by the prerequisite

Frequent Contributor

Hi there,

 

I would like to get some feedback and raise awareness about an issue I have encountered at a customer which lead me to question the prerequisite UCMA 4.0 as part of Exchange 2016 / 2019 mail role on Server 2016 / 2019.

 

by fact UCMA is not supported on either of these Windows Server OS (refer download prerequisites)

The one that is supported is UCMA 6.0

The docs appear like nothing changed since Exchange Server 2013, which is not the case as there have been 2 subsequent major releases of UCMA since. 


"The UCMA 4.0 runtime is specifically required. If you’ve installed any other version of UCMA, you are in a non-supported state. The Exchange team is responsible for supporting their pre-requisites."

Is this statement bonkers or would the Exchange Server seriously argue against your own mesh of supportability which seem to exclude your prerequisites? 

 

I would like to plea: change docs, change version checks of UCMA in setup / CUs. Update to UCMA 6.0 when Exchange is running on Server 2016 / 2019 (for Ex2019 no question as only 2019 is supported at the moment)

 

Fix the UCMA 6.0 setup to no demanding the outdated C++ Redist 2015-2019 x64 14.12. but also accepting the currently secured version 14.28.

Dear Exchange Team, thank you for your time and feedback. 

 

1 Reply