Exchange 2013 The certificate key algorithm is not supported

Copper Contributor


We have an Exchange 2013 server, updated to CU23, which worked fine until one day, it showed the error on OWA "The certificate key algorithm is not supported"!
I tried to put back an older valid certificate, reactivate all ciphers and TLS, updated to latest Microsoft patches, this error still comes back and I cannot manage the server anymore!
Anyone has a clue how to resolve this issue?

8 Replies
Can you check in IIS which Certificate is selected?

I tried them all, even the one installed originally by Exchange, none are working, they all generate this error.

1. Please check to enable TLS 1.2 and cipher by the IIS Crypto tool.
Technical reference details about encryption
2. Please check the same on your client's PC.
PS. I recommend reviewing or creating GPO for TLS 1.2 and cipher
Server cipher suites and TLS requirements

Exchange Server TLS guidance, part 1: Getting Ready for TLS 1.2


I already configured the proper ciphers with IISCrypto before it started doing this issue. I then tried many, many, many different settings in case one would work, but the error stays the same. I did not notice when this issue started because I am not using OWA/ECP often, but I can assure that when I installed the latest SSL certificate, it was working properly.

Please check and install .NET Framework 4.8 and all windows update.


After the update, please check TLS .Net.


Transport Layer Security (TLS) best practices with the .NET Framework

Update and configure the .NET Framework to support TLS 1.2


As mentioned, it was working few months back, so TLS 1.2 is already activated and working. The server is 2012R2. I installed .Net 4.8 just in case it would make any difference, but not. How to troubleshoot what is the error exactly and what triggers it? It would be preferable to pinpoint the source of the issue instead of trying settings and installation of programs...

Interesting fact I forgot to mention, the login screen appears correctly, it is after logging in that the web page shows this error.

The certificates are fine. I tried several and they are all doing the same error. The only workaround I found so far is to use basic authentication, FBA returns this error but not basic authentication. The conclusion is therefore that FBA cannot authenticate the user to the domain with this error. How to troubleshoot FBA authentication process? How to know which one of the three configured it tried (NTLM, etc) and how to troubleshoot? Is it worth trying another mean of authentication through FBA? I'm asking, because I just spent over 48 hours almost straight trying to find a fix and soon, building a new server will make more sense, but fixing this one would be much preferable, there must be a way to troubleshoot issues with Exchange!! Or is it just trial and errors until you get lucky, and if so, go buy beers and lottery tickets?