Exchange 2010 SP3 Upgrade failing Organization Checks

Copper Contributor

Hi 

 

I'm working on a project to remove the last Exchange 2003 server from the Exchange 2010 organization, which has now completed.

 

Next phase is to introduce an Exchange 2016 Server into the existing 2010 org and setup for coexistence prior to migration.  The main issue is that I need to upgrade all Exchange 2010 SP1 servers  to SP3 to support Exchange 2016 and in production this is failing the Organization checks.

 

The upgrade worked fine in UAT, which uses the same AD functional level (Windows Server 2008R2) and consists of all Windows Server 2016 DCs, same as production.

 

Since starting to update production 2010 servers I receive the following message after the Organization checks fail:

 

nitrox2000_1-1718121450438.png

I have tried to update to SP2, which was a mission to find the installer as it is ancient (same as Exchange 2010 I know!), but to the same result and have tried everything to resolve the issue but to no avail.

 

Current Prod

AD Schema version = 87 (Windows Server 2016)
Exchange Schema rangeUpper = 14726

 

Current UAT

AD Schema version = 87 (Windows Server 2016)
Exchange Schema rangeUpper = 15334

 

I have read that the solution may be to add a legacy Windows Server 2012 as there is a problem with SP3 updates on Server 2016 DCs, but it worked on these fine in UAT so I'm rather perplexed as to this being the only solution.

 

Can anyone give me further advice as to what could be attempted next please? - Before we bite the bullet and introduce a legacy 2012 server just to upgrade to Exchange 2010 SP3 and then remove as soon as done, assuming it works!!

 

Please any suggestions would be greatly received?

 

Thank you

 

MB

 

0 Replies