SOLVED

Exchange 15.2 and Outlook 2016 popup credentials problem

Copper Contributor

Hello everyone.
I just finished an installation of Exchange Server 2019 on premise on my LAN, in DAG configuration with FSW and with a Load Balancer in my DMZ (Kemp).
The version I am using is Version 15.2 (Build 1544.4). I share a common nemespace internally and externally. I have extended protection enabled and EnableDownloadDomains set to True.
My domain is Windows Server 2016 with functional level 2012R2.
All inbound and outbound mail flow is working fine.

 

However randomly Outlook 2016 shows a popup and asks for credentials on startup. After closing the popup it does not appear again and everything works fine.

 

Doing some research I came to a post that explained how to set up an ASA and I understood that this would solve the popup problem on Outlook startup.
This is the post: https://tkolber.medium.com/https-medium-com-tkolber-configure-kerberos-authentication-with-exchange-...

 

Although I performed this process well and according to my Exchange logs (Mapi, OAB, Autodiscover) Outlook would be authenticating with Kerberos, I am still experiencing the popup when starting Outllok. Actually, the authentication is being performed with Negotiate.

Could someone help me to understand where is the fault that causes the credentials popup?

 

I copy some sample logs:

 

2024-04-16T17:03:06.028Z,195e355f-e6be-4574-98e6-a79fde50e72c,15,2,1544,9,R:{766D4B87-509D-4014-B972-1A3E7F262640}:39;RT:PING;CI:{F6B5A6A8-9013-4D1D-9262-7F4F7A19BE6A}:10;CID:{9EE05D18-0453-4162-AAA5-4928EFDCDE3A},Mapi,mail.contoso.com,/mapi/nspi/,,Negotiate,true,NUEVENET\alan.wake,mail.contoso.com,MailboxGuid~7601c8b5-c0f9-4b20-86d2-b87ac37aeeea,Microsoft Office/16.0 (Windows NT 10.0; Microsoft Outlook 16.0.4266; Pro),192.168.20.18,S-EXCH01,200,200,,POST,Proxy,s-exch01.nuevenet.medios,15.02.1544.000,IntraForest,MailboxGuidWithDomain,Database~177fa612-1ee6-445f-9d05-39634c748741~~2024-05-16T16:55:28,,,0,83,,,1,0,,0,,0,,0,0,,0,22,0,,,,17,1,0,0,1,0,21,0,19,3,4,5,22,,?MailboxId=email address removed for privacy reasons,,BeginRequest=2024-04-16T17:03:06.005Z;CorrelationID=<empty>;ProxyState-Run=None;FEAuth=BEVersion-1942128136;NewConnection=fe80::9283:b9b0:959d:9b9%12&0;BeginGetResponse=2024-04-16T17:03:06.010Z;OnResponseReady=2024-04-16T17:03:06.027Z;EndGetResponse=2024-04-16T17:03:06.027Z;ProxyState-Com

 

2024-04-16T17:12:18.915Z,9677cf87-d77e-4eb1-a15f-dd84b44d7266,15,2,1544,9,{2161BC61-98F4-499A-BA1A-5F407BC6651B},Autodiscover,autodiscover.mail.contoso.com,/Autodiscover/Autodiscover.xml,,Negotiate,true,NUEVENET\alan.wake,mail.contoso.com,Smtp~email address removed for privacy reasons,Microsoft Office/16.0 (Windows NT 10.0; Microsoft Outlook 16.0.4266; Pro),192.168.20.18,S-EXCH01,200,200,,POST,Proxy,s-exch01.nuevenet.medios,15.02.1544.000,IntraForest,AnchorMailboxHeader-SMTP,Database~177fa612-1ee6-445f-9d05-39634c748741~~2024-05-16T16:14:43~nuevenet.medios~0,,,356,6043,,,16,0,,0,,0,,0,0,,0,58,0,0,2,0,37,0,0,0,1,0,42,0,38,3,5,21,58,,,,BeginRequest=2024-04-16T17:12:18.856Z;CorrelationID=<empty>;ProxyState-Run=None;FEAuth=BEVersion-1942128136;RoutingEntry=DatabaseGuid:177fa612-1ee6-445f-9d05-39634c748741%40nuevenet.medios%40nuevenet.medios Server:S-EXCH01.nuevenet.medios+1942128136@638488749313561811;NewConnection=fe80::9283:b9b0:959d:9b9%12&0;BeginGetRequestStream=2024-04-16T17:12:18.875Z;OnRequestStreamReady=2024-04-16T17:12:18.877Z;

 

2024-04-16T15:11:50.330Z,08ea953f-cdd4-4140-8ded-ab0514a6a6a6,15,2,1544,9,,Oab,mail.contoso.com,/OAB/1dbe7412-1758-4c9f-9dc2-1a074b690480/oab.xml,,Negotiate,true,NUEVENET\alan.wake,,Sid~S-1-5-21-1813983981-3280950500-419316427-8134-UserADRawEntry~CN=SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c} CN=Users DC=nuevenet DC=medios,Microsoft BITS/7.8,192.168.20.18,S-EXCH01,200,200,,HEAD,Proxy,s-exch01.nuevenet.medios,15.02.1544.000,IntraForest,WindowsIdentity-OABOrgMailbox,,,,0,0,,,24,61,0;,0,1;,1,,0,1,,0,516,0,,,,315,5,,,19,1,488,4,357,172,177,201,516,,,,BeginRequest=2024-04-16T15:11:49.814Z;CorrelationID=<empty>;ProxyState-Run=None;AccountForestGuard_nuevenet.medios=1;GlsGuard=1;FEAuth=BEVersion-1942128136;RoutingEntry=DatabaseGuid:a5f2df71-6a42-4bd7-8509-6436415e85c5%40nuevenet.medios%40nuevenet.medios Server:S-EXCH01.nuevenet.medios+1942128136@638488749313571819;NewConnection=fe80::9283:b9b0:959d:9b9%12&0;BeginGetResponse=2024-04-16T15:11:49.973Z;OnResponseReady=2024-04-16T15:11:50.288Z;EndGetResponse=20


I thank you in advance for any information you can provide me to solve this problem.

 

Best regards,

Gabriel

1 Reply
best response confirmed by _neok (Copper Contributor)
Solution
I fixed it by installing Outlook 2016 updates.
1 best response

Accepted Solutions
best response confirmed by _neok (Copper Contributor)
Solution
I fixed it by installing Outlook 2016 updates.

View solution in original post