Error while "Batch migration to migrate Exchange Server public folders to Exchange Online"

%3CLINGO-SUB%20id%3D%22lingo-sub-2216616%22%20slang%3D%22en-US%22%3EError%20while%20%22Batch%20migration%20to%20migrate%20Exchange%20Server%20public%20folders%20to%20Exchange%20Online%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2216616%22%20slang%3D%22en-US%22%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EHi%20there%2C%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EI'm%20currently%20in%20the%20process%20migrating%20OnPrem%20Exchange%202013%20public%20folders%20to%20M365.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EMy%20problem%20is%2C%20that%20the%20PowerShell%20script%20%22%20Sync-ModernMailPublicFolders.ps1%22%20provided%20by%20Microsoft%20throws%20the%20following%20errors%3A%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22OSuperfly_1-1615971284983.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F264765i4C0D018A982A2CA8%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22OSuperfly_1-1615971284983.png%22%20alt%3D%22OSuperfly_1-1615971284983.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E(see%20attached%20screenshot)%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EI'm%20sorry%20it's%20in%20german%20language%2C%20I'll%20try%20to%20translate%20that)%3A%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3ERemoveMailEnabledPublicFolder%20%3A%20The%20name%20%22Remove-EXOSyncMailPublicFolder%22%20was%20not%20recognized%20as%20the%20name%20of%20a%20cmdlet%2C%20function%2C%20script%20file%2C%20or%20executable%20program.%20Check%20the%20spelling%20of%20the%20name%20or%20whether%20the%20path%20is%20correct%20(if%20included)%20and%20try%20again.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%3CSPAN%3EThe%20environment%20consists%20of%203%20servers%2C%20the%20Hybrid%20ist%202016%20CU18.%20All%20have%20KB5000871%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22OSuperfly_3-1615971356661.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F264766iB536575F7BD4D3FF%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22OSuperfly_3-1615971356661.png%22%20alt%3D%22OSuperfly_3-1615971356661.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EI%20also%20tried%20to%20execute%20the%20script%20on%20the%20other%202%20servers%2C%20without%20result.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EAny%20idea%3F%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EOliver%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2216616%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%20Server%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHybrid%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hi there,

I'm currently in the process migrating OnPrem Exchange 2013 public folders to M365.

 

My problem is, that the PowerShell script " Sync-ModernMailPublicFolders.ps1" provided by Microsoft throws the following errors:

 

OSuperfly_1-1615971284983.png

(see attached screenshot)

I'm sorry it's in german language, I'll try to translate that):

 

RemoveMailEnabledPublicFolder : The name "Remove-EXOSyncMailPublicFolder" was not recognized as the name of a cmdlet, function, script file, or executable program. Check the spelling of the name or whether the path is correct (if included) and try again.

 

The environment consists of 3 servers, the Hybrid ist 2016 CU18. All have KB5000871:

 

OSuperfly_3-1615971356661.png

I also tried to execute the script on the other 2 servers, without result.

 

Any idea?

Oliver

2 Replies
I've possibly found the problem, but I need help from Microsoft:

It seems that the required EXO Powershell commands aro no longer available in Exchnage Online Powershell!

The provided PowerShell script "Sync-ModernMailPublicFolders.ps1" by Microsoft referres to the EXO commands:

- Remove-EXOSyncMailPublicFolder
- New-EXOSyncMailPublicFolder
- Set-EXOMailPublicFolder

Uhmmm Microsoft?

If you are still facing error while "Batch migration to migrate Exchange Server public folders to Exchange Online.

 

Check out this post: Power Shell Command-line like New-MoveRequest Cmdlet

 

After reading this post, you will know about New-MoveRequest Cmdlet.

 

Hope it works