ECP Redirect to url for exchange server in another AD Site

Occasional Contributor

I'm working with a client who has been having an issue with ECP for a few years now, but has become a much larger problem recently.  All mailboxes have been moved to O365 and we therefore changed autodiscover to point to (this is important).  We have no mailboxes on-prem as the servers are licensed with a Hybrid license and having mailboxes homed on-prem would be out of license compliance (also important).

From the exchange server in the AD Site "LA", when I try to go to the ECP using https://localhost/ecp or https://IPADDRESS/ecp or I get redirected to This worked (but was really really slow) up until we changed to point to  Now we can't access the ECP at all.

The exchange server was a brand new installation in February.  And this has been happening on all their exchange servers for a few years at least.  They have 2 exchange 2013 servers in the environment that will be decommissioned soon (these servers are in a different AD Site than the LA server) and 2 exchange 2016 CU15 servers (one in each of the AD Sites).

If my admin account had a mailbox homed on-prem, I would be able to use the URL and it would not redirect.  But due to licensing compliance, keeping a server on-prem is not an option.  We have looked all through IIS and cannot find any redirects, and certainly did not configure any when we installed Exchange.  When we installed the other new 2016 server, we immediately had the same redirect with no configuration changes post installation.  So this appears to be at an organization level, but I don't see anything glaringly obvious with "Get-OrganizationConfig | FL".  I see nothing in the web.config files.  I don't know where to look next.

4 Replies

Hello @Raechel Moermond 

If i understand correctly , you want to reach your ECP Url on the On Prem Hybrid , but without luck.

Have you checked that he ECP Virtual Directories for the INTERNAL url are correct ? ( the URL you try to reach basically ) ? Also Important did you checked the OWA Url matches the ECP Url , also Internal ?

And finally whatever URL is the ecp e.x : , the FQDN must be included on your Certificate , or at least a Wildcard Certificate for the Domain should exist

A common mistake also is the DAG. Remember the DAG is NOT the CAS Endpoint , just a reminder here maybe it switches something. It really gets me though the issue like it is an issue that is going on for a long time..... Don't fear to change the Exchange and have a look on your Virtual Dirs ECP in relation with OWA. You can also recreate them without messing anything at all and to tell you truth it is not a common thing to point to the autodiscover Endpoint. Use a DNS resolvable FQDN, and avoid Server Names.


@Raechel Moermond 

I need to know a few things about your current configuration of virtual directories. you can simply run the below Cmdlets in the Exchange Management Shell, and let me know the config, so I can help you with this.



  make sure you replace your domain name with something similar like "Contoso.Com" before you post your configs. you can simply use find/replace and replace "" with "Contoso.Com" in notepad, and post the results here. other things in the generated output are not sensitive info, then relax.



Start-Transcript dvconflog.txt
Get-EcpVirtualDirectory | fl server, Name, *URL*, *auth*
Get-OwaVirtualDirectory | fl server, Name, *URL*, *auth*
Get-ClientAccessService | fl Name, OutlookAnywhereEnabled, AutodiscoverServiceInternalUri
Get-ClientAccessArray | fl
Get-ExchangeServer | fl *version*






There is no DAG, so that's not a concern.  on the LA server, all internal URLs are set to the server name (https://server.fqdn/ecp, https://server.fqdn/owa, etc.).  On the old NZ server and the old AU server (that will be decommissioned), the internal URLs are set to the server name and the external URLs are set to  The new NZ server is set like the LA server - internal URLs only.


@behrooz amiri 

I'm running those commands now, but it will take a long time as the exchange servers are in different AD sites and there seems to be some trouble getting the NZ and AU exchange settings in a timely manner from the LA server.


@behrooz amiri 

I've attached the output.  I'm currently recreating the virtual directories.  we'll see what that does.


Edit to add: recreating the virtual directories did absolutely nothing for me, as I expected.  I've also tried "" which is now pointing to the LA server and it all redirects to  It simply doesn't matter where I start, what server, or what browser I use, something above the server level (since these are new servers and even localhost redirects) is redirecting ECP.