Copied sent items of shared mailbox not recognized by 3rd party mail systems

Highlighted
Occasional Contributor

We have in Office 365 / exchange online, multiple shared mailboxes where the option MessageCopyForSentAsEnabled is true. This way as somebody sent an email with the shared mailbox as sender, it doesn’t only appear in the sent items of the sender but also the sent items of the shared mailbox. This works perfectly

On top of that, on some shared mailboxes a forward is set to an external address. This gives some unexpected behaviour. Apparently exchange online doesn’t copy the mail to the send items of the shared mailbox but e-mails it to the shared mailbox with probably an extra header or something. The shared mailbox recognises it as a sent item and moves it to the sent items folder.

Because it is emailed instead of copied, it also gets forwarded to the forward address. If the forward address is hosted on a MS email system it is also moved to the sent items. If the forward is hosted on a non-MS system the following email appears in the inbox:

“The attached message was sent by a member of this shared mailbox. Usually, it would appear in Sent Items, but your service is currently being upgraded. Things will be back to normal after the upgrade.“ 

Does anybody have an idea how this behaviour can be fixed apart from setting up an inbox rule which deletes the e-mail?

6 Replies
Highlighted

It's definitely "known", but I haven't been successful as to obtaining a proper answer if it's a bug or a feature. I have a more detailed article on it here, including and explanation of why it works like this (sort of): https://www.michev.info/Blog/Post/1947/messagecopy-settings-and-forwarding

 

But if you want an official answer, best open a support case.

Thank you for the link, it perfectly explains what's happening. I did open a support request and the answer is, that it's a feature. Here the response I got:

Thank you for your time today, as we discussed I have further tested this and found that the behavior is by design.

Basically since the option to save a copy of the sent items was added in the Portal the behavior changed, the shared mailbox is sending itself an email with the item that is then moved to the Sent items folder.

These emails have a form of trigger that moved them to the Sent items folder, for Office 365 mailboxes, for external addresses the might not recognize this trigger and this is why they are not moving them to the Sent items.

I will be checking if there is a way to block these emails from being sent to the forwarding address.

 

Probably the only way to block it, will be via a transport rule, but I'm not a big fan of that solution. Let's see what support will come up with.

Highlighted

Well, you can always leave feedback on this with your Microsoft TAM and even ask for a design change, but to be honest I don't find it that big of a deal.

Highlighted

We still have to problem and i link to this thread.

Anyone have found more information or a setting to change the configuration.

 

The problem on our site is, that it makes the Mailarchiv 3rd party Software fail, because it can't handle the mails.

Highlighted

I haven't found a solution for this. We decided to live with it for now. We disabled the setting to keep a copy in the shared mailbox (with a external forward) for sent items.

Highlighted

If you are running only Outlook for Windows and don't use OWA at all, this add-in could help.